2

When I right click a .php file in Windows explorer, and hover over "Open with", it displays my regular Firefox, but not Firefox Developer Edition as an option.

If I select "Choose default program...", click "Browse...", navigate to "Program Files (x86)\Firefox Developer Edition" and select firefox.exe, it still shows the regular Firefox icon, and will still open with the regular Firefox.

I think the issue is that both programs are called firefox.exe. Is there some way I can fix this behavior?

  • Does FDE have to be only in the Open with menu for PHP files, or is adding it elsewhere an option? – Karan Apr 15 '15 at 23:52
  • @Ramesh's solution below is good (adding it to "Send to"), but it would be preferable in "Open with". – nHaskins Apr 16 '15 at 23:53
0

Since both editions of Firefox uses the same executable name, this problem happens. As a workaround, you may use add the Firefox Developer Edition to the "Send To" dialog, using these steps:

Click Start, type shell:sendto and press {ENTER} The Send To folder opens. Create a shortcut to Firefox Developer Edition in the Send To folder.

You can simply right-click on a .PHP file, click "Send To", and choose Firefox Developer Edition.

  • This works, although I would still prefer to get it in "Open with" if it's possible. – nHaskins Apr 16 '15 at 23:51
  • You can rename Firefox Dev Edition executable to FirefoxD.exe and use the Open With dialog (browse...) to select the application. It would automatically be added to the Open with dialog. – Ramesh Apr 17 '15 at 4:38
  • Another option is to add Firefox Dev Edition to the context menu of PHP files. If you prefer, I'll construct a REG file for the same. – Ramesh Apr 17 '15 at 4:40
  • Wouldn't renaming the Firefox executable break things? Even if it didn't, would it need to be redone every time there was an update? – nHaskins Apr 20 '15 at 18:35
0

I don't have Firefox Developer Edition installed but hopefully this will work:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\.php\OpenWithList\Firefox.exe]

[HKEY_CURRENT_USER\Software\Classes\.php\OpenWithList\FirefoxDE.exe]

[HKEY_CURRENT_USER\Software\Classes\Applications\Firefox.exe\shell\open\command]
@="C:\\Program Files (x86)\\Mozilla Firefox\\Firefox.exe \"%1\""

[HKEY_CURRENT_USER\Software\Classes\Applications\FirefoxDE.exe\shell\open\command]
@="C:\\Program Files (x86)\\Firefox Developer Edition\\Firefox.exe \"%1\""

Edit the paths to the two Firefox executables if they are incorrect, then save as a .REG file, double-click and import.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.