3

Running Windows 8.1 and trying to rename a file using the Navigation Pane in File Explorer (the left hand panel aka folder view) is a game of beat the clock for me at the moment.

That's because every few seconds something is iterating over the folders in that panel. So a folder in rename/edit mode quickly either has all text selected (so next key press overwrites all previous key presses) or focus is lost.

If i just use the context menu and select rename, and watch, i can see a flash of arrows just briefly (like when you hover over with the mouse tho I've moved my mouse away previously) and a flicker of the text before all text is selected and focus is lost.

This only happens in the Navigation Panel, not in the Details panel... which consequently has become the workaround. And it happens on any drive or folder.

Nothing appears to be iterating when a folder is not in rename mode. No flickers or flashes. No excessive CPU or memory usage.

I've turned off all usual suspects:

  • Windows Search
  • Windows Defender
  • Killed all processes down the point of just what's needed to keep the OS stable.

I'd like to be able to use "some utility" point it at a folder and then have it report every process that accesses that folder.

To iterate is to read, yes?

I've tried process explorer but it doesn't seem to be showing anything useful though I'm not necessary using it in an advanced manner. I'm just listing all processes and filtering for directory accesses.

How can I intercept this iteration?

Update 1 :

Ok so it helps to be using the proper tools. Mine were hopelessly outdated (Process explorer 2012). By updating to ProcMon 3.1, as per comments, I can get a much better handle on this via improved filtering:

So it seems the Nav Panel IS being iterated even when a folder is not in rename mode. However it is only being iterated when the drive is expanded and if I collapse the drive then it stops iterating.

Uneventful

Eventful

When it is iterating it is generating exactly 20 events every 7 seconds as below:

enter image description here

Does this pattern look familiar to anyone?

Note: The drive and folder is irrelevant. This happens for any combination of drive and folder. Also PID 6084 is explorer.exe and that this is aberrant behaviour as a quick test on other pcs tells me they don't iterate / keep polling in this way.

8
  • 1
    If you boot into a minimal boot configuration does this happen? – Ramhound Apr 16 '15 at 10:50
  • Is this computer networked? If so, does the issue occur when temporarily disconnected? That would determine if its a remote process. You might find Process Monitor, technet.microsoft.com/en-us/sysinternals/bb896645, helpful. – DrMoishe Pippik Apr 16 '15 at 13:08
  • @Ramhound If I boot into safe mode via msconfig.exe this does not happen. i.e. problem solved. So whats the easiest way to do a diff on safe mode vs normal mode these days? thx. – rism Apr 17 '15 at 1:33
  • @DrMoishePippik Yes it is in peer to peer workgroup. I had thought of that and tried disconnecting from network both physically and logically but it doesn't appear to affect the problem. That said Im using a 2012 version of procmon so will upgrade and have another play. – rism Apr 17 '15 at 1:35
  • Use Autoruns and one-by-one add additional drivers and processes to the boot configuration. Its a slow progress but you have confirmed that there is a process that is causing this behavior. – Ramhound Apr 17 '15 at 1:49
0

Well finally after all these months I've stumbled across the problem: Corsair Link.

After installing Windows 10 and updating my drivers for a tv card, I noticed in the now very prominently displayed Devices tab that something called PMBus Bridge was repeatedly trying to install itself.

I didn't notice this in the old Windows 8 devices tab, but in Windows 10 each device has a long card with progress bar running under it, so it was very obvious.

One of the first things I checked after I installed Windows 10 was whether this weird problem has ceased but it hadn't. But with this fresh in my mind, I noticed the attempted install of PMBus (Power Management Bus) Bridge had a similar frequency to the behavior described in my question.

When i tried to remove the PMBus device, the File Explorer scanning stopped. But then PMBus would try to reinstall itself again and the scanning would restart.

Anyway to cut a very long short I tracked down a relationship between PMBus Bridge and Corsair Link. Having updated the drivers for Corsair Link, the problem is no more, even after several reboots.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.