Whenever I try to add any site to favourites (by dragging it to favorites bar/Alt-Z/Ctrl+D/clicking in UI) nothing happens.

The Favorites dir in my %userprofile% exists, is writeable, and has items.

Interestingly though the All Users equivalent seems broken:

C:\Users\All Users>mkdir Favorites
A subdirectory or file Favorites already exists.

C:\Users\All Users>cd Favorites
The system cannot find the file specified.

I'm testing with IE 11.0.09600.
I've tried resetting user settings. (inetcpl.cpl -> Advanced -> Reset)

  • If I may, which version of Windows were you utilizing throughout this scenario? – Run5k Mar 7 '17 at 16:04
  • @Run5k Blimey. 2 years ago. Hmm. Probably Windows 7. – RJFalconer Mar 8 '17 at 9:52
  • 1
    Probably so… I was just wondering based upon the C:\Users\All Users reference point. Regardless, can you potentially do us a favor and flag your own answer as the officially accepted solution? Thanks in advance! – Run5k Mar 8 '17 at 13:14
up vote 1 down vote accepted

I found the answer in this article.

Somehow my registry had entries that were mapping the Favourites folder to a disk that did not exist.

By correcting the "Favorites" keys in these locations and restarting IE the problem was resolved:

HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\Shell folders
HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\User Shell folders
HKEY_USERS\.default\Software\Microsoft\Windows\Current Version\Explorer\Shell folders
HKEY_USERS\.default\Software\Microsoft\Windows\Current Version\Explorer\User Shell folders

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.