16

I'm having a problem where the Finder uses WAY too much CPU time. It's using up to 100% of one of my cores.

I'm running 10.6.2 on a MacBook Pro w/ 6GB of RAM, plenty of fast (SSD) disk space. I also run DropBox and BackBlaze.

I've tried disabling my third party stuff (DropBox and BackBlaze), but that doesn't seem to help. It's killing my battery life!

14

I think I found my problem—one or more of the files on my desktop.

After moving the various clutter off my desktop, the Finder stopped using so much CPU.

I suspect that it was either calculating folder sizes (as Benjamin Schollnick mentioned) or maybe trying to create an icon preview.

3
  • 2
    Damaged Icon's have been known to be issues for the Finder, if you have Show Icon Preview turned on as well. Jan 2 '10 at 14:17
  • Had a similar issue, tried a bunch of different fixes (removing the finder plist file e.g.) with no results. Discovered I had a large (164 MB) movie file on my desktop, removed it, and my CPU went back to normal. Jul 2 '12 at 21:14
  • This issue actually gets worse when editing an image residing on your desktop with Preview. The auto save option introduced with Lion, forces the file into a state where the Finder needs to recreate its preview icon almost every 20sec. Jan 2 '13 at 14:26
10

Check Finder --> View --> View Options

If you are viewing a folder, especially one that has subfolders, and you have Calculate Folder Size turned on, the finder will have to go through and "size" all the folders...

I noticed that my Mac Pro will take about a minute or two minutes of nearly 100% usage when I initially turn that on, or if I start viewing the disk from the root.

Try turning that off and see if that resolves your issue... It's a work around, but it'll help isolate the issue.

1
  • 1
    I think that the solution I found points to this being a possible element...
    – jerwood
    Jan 2 '10 at 6:30
6

An easier way to restart Finder is to option-click on its icon on the Dock and choose "relaunch".

This works for a while for me, but the reason behind Finder using so much resources is tick on the box "calculate all sizes" as you said. This takes up much energy especially after major reorganizing/cleaning up the harddrive.

2
  • 1
    All sizes are usually only calculated for open windows, and no big issue e.g. for /Applications. It's a really bad idea for the disk root directory, though.
    – Daniel Beck
    Jan 21 '11 at 10:00
  • This worked nicely for me where the other answers here didn't. Thanks :)
    – John Hunt
    Jun 26 '20 at 15:04
2

I had Calculate Folder Size on previously and had the problem. Unchecking that box was a workaround but Delete Library/Preferences/com.apple.finder.plist and logging out & back-in seems to have fixed it.

1

Does this happen as soon as finder is launched? ie. as soon as you login after a restart?

Try opening a terminal and typing

killall Finder

That will quite Finder. Finder will then restart itself. If the CPU usage is still at 100%, then try creating a new user account and seeing if the same happens on that user account. (This will confirm whether or not the problem is with the finder or with something you've done on your own account).

If you still see high cpu usage on the new user account, then something is probably wrong and you should probably call Apple.

1
  • I tried killing the Finder, but upon restart it would resume taking massive CPU.
    – jerwood
    Jan 2 '10 at 6:29
0

It's Dropbox causing it for sure. Same happened to me on Mac OSX Lion 10.7.2. Turned off Dropbox and immediately stopped. It seems to happen when viewing "All My Files" with Dropbox running.

0

All answers are correct: apart from the occasional hang, that is fixed after a restart, this is happening due to:

1 - long tasks left in the background, such as the "get info" on a very deep folder

2 - Dropbox / iCloud / Onedrive / Google drive / any other cloud software, by using any of these a lot goes on the finder to render additional icons or having to deal with a lot of simultaneous file updates

3 - some files dropped on the desktop - as a consequence of no. 2, since the desktop is quite always a cloud folder (defaults with iCloud)

0

I used an app called "Activity Monitor" to find out which apps were consuming a disproportionate amount of CPU, making it difficult for other Apps to garner CPU time. It was the Finder, which was consuming between 60% and 100% + of CPU time. So I looked for some files I recently had added to my desktop that might be forcing the Finder to use more CPU than it should, found them, and moved them off the desktop. Bingo - no more Outlook SWOD problems. (Both of the files moved off the desktop were database files; fyi).

0

The answer is actually STACKS, it is a terribly designed feature that will slow your computer to a crawl with 150% finder CPU usage. The second STACKS is disabled by Right Clicking on the Desktop and deselecting "Use Stacks" your computer will instantly run faster.

Tested and Works - Mac Pro (2019) 1,589 Icons

3.2 GHz 16-Core Intel Xeon W

32 GB 2933 MHz DDR4

AMD Radeon Pro W5700X 16 GB

(6) 4k LG HDR 4K Display

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 8 '21 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.