17

Does anyone know how to turn off the hateful behavior that is now default in Gnome Terminal — when a key is pressed the mouse pointer hides until it is moved again.

I'm honestly ready to switch Linux distros to something Gnome-free after hours of trying to get this to not happen. It's completely slowing me down / killing my productivity...

  • I'm on the latest Fedora, btw. – BadZen Apr 17 '15 at 18:22
  • 3
    As someone who regularly uses multiple application windows in my workflow, I completely understand your frustration. Rather than recompiling GNOME terminal (which really should be marked as the correct answer), I suggest you install ROXTerm: sudo apt-get install roxterm It was originally designed as a GNOME terminal but without the dependency on GNOME libraries. It also hides the cursor in a more logical manner! – wayfarer_boy Oct 26 '15 at 15:21
  • 2
    Also in light of comparing both side by side, I see what I /really/ wanted was for the cursor to always unhide on mouse move - not require a click - and not to disable hiding altogether. Though @egmont's response still might answer my Q as asked... – BadZen Oct 27 '15 at 16:15
  • 2
    The bad behavior (reported at bugzilla.gnome.org/show_bug.cgi?id=725342) is caused by missing focus in/out events (bugzilla.gnome.org/show_bug.cgi?id=677329) which just got fixed in Gtk+: git.gnome.org/browse/gtk+/commit/?id=d55b815 – egmont Feb 12 '16 at 22:51
  • 1
    what the F! Yes this is it (Fedora 22), it hides the mouse and unless you click on it it does not appear. I use Cinnamon on Fedora, I abandoned most of gnome applications (editor is now useless) still used gnome-terminal, time to also ditch that one. – dashesy Mar 6 '16 at 17:05
4

Gnome-terminal doesn't have an option to disable hiding the mouse cursor. Moving the mouse will sometimes unhide it (not sure what the criterion is) and sometimes not. Many times you have to (as you have already noticed) actually click on the Window to unhide it. The problem with this is that if you have multiple terminal windows and multiple monitors, with the cursor hidden, you have no idea where you're clicking.

The resolution is to change the default terminal to a different emulator such as xfece4-terminal or as mentioned in the comment roxterm.

You'll also have to change the default terminal emulator to bring up your new configuration by default with:

$ gsettings set org.gnome.desktop.default-applications.terminal exec 'xfce4-terminal'

(Change xface4-terminal in the command to your alternate emulator.)

0

This is a bug in gnome-terminal: Mouse cursor sometimes hides if Terminal is focused

The bug is now marked as RESOLVED FIXED, so it might soon reach your distribution:

The fix has made it into the official Gtk+ 3.18.9 tarball, and in turn, has already appeared in Debian Unstable and in Ubuntu Xenial beta.

James' answer solves the problem, but for those unsure about messing up with their system, enduring the bug for a few more weeks until your distribution updates gnome-terminal is the safest option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.