My PC clock was wrong, (Time Service not running), and I decided to fix it.

I tried this

"Once you have opened regedit, navigate to the following registry key:

HKLM\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl\services\TapiSrv Now in the right pane right-click on ImagePath and select Modify. Here in the Value data box, make sure that the value is:

%SystemRoot%\System32\svchost.exe -k NetworkService "

Once I rebooted, the internet connection was lost.

I tried:

  1. Rebooting the PC and the router
  2. Disabling and reenabling the adapter,
  3. ipconfig /release /renew,
  4. changing the -k parameter to LocalSystemNetworkRestricted and service -> Telephony logon to local
  5. ipconfig /flushdns -> nbtstat -R -> nbtstat -RR -> netsh int ip reset c:\resetlog.txt -> netsh winsock reset
  6. Booting into safe mode (with networking)
  7. Change image path in Tapisrv to have -k NetworkService and then went in to the Logon tab and set it to 'this account' 'Network Service' and blank passwords.
  8. Disabled windows firewall, anti virus is Windows Defender

it is a dual boot system. If I boot into ubuntu , no internet problems.

I can see the router in Windows, so it sees the router but will not go through to the internet.

For what is it worth, the pc is a custom build with the following specifications

CPU: Intel i5 3570k @3.4GHz RAM: 8GB DDR3 Motherboard: Gigabyte Z77X-UD3H Graphics: Nvidia 2GB 660 Ti Storage: 119GB OCZ-Vertx4 SSD & 3TB Seagate St3000DM001-1CH166(SATA)

Any ideas how I can get back online?

  • Undo that change to the registry. That registry key has nothing to do with the clock but everything to do with your internet connection. – ojs Apr 18 '15 at 15:54
  • How do I undo? Unfortunately I didn't make a record. Can I roll it back to yesterday? – SeanJ Apr 18 '15 at 16:27
  • HKLM\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl also has ControlSet001...002... try comparing it with these. – JasonXA Apr 19 '15 at 14:13
  • Good suggestion. I checked ControlSet001, unfortunately -k NetworkService. Maybe it is propagated after reboot? – SeanJ Apr 19 '15 at 17:24

Why not just perform a system restore selecting a restore point prior to the date you tampered with your registry values. This should restore your registry to the state as at the chosen restore point.

Run rstrui.exe and follow the instructions

  • Genius! Thanks so much. I had tried this in the pre boot troubleshooting menu and it said there was no restore, so I just presumed there was no restore point. When I ran rstrui.exe, lo and behold, three restore points. Back in business, thanks a million. Also, checked the registry. %SystemRoot%\System32\svchost.exe -k NetworkService . I remember changing it because it was different so can't understand why it is the same. I booted up tried to change the clock and bang no internet. Mystery to me. Céad míle fáilte romhat! – SeanJ Apr 19 '15 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.