3

When compatibility view has been disabled in all ways possible it seems that Internet Explorer 11 on Windows 8.1 honours a website’s X-UA-Compatible value. This happens outside of compatibility view (the icon is missing from the address bar) and is not caused by compatibility lists or a <!DOCTYPE> directive.

Is there any way for the user (not the web developer) to choose a document mode for a website, overriding the website’s X-UA-Compatible value?

Force Internet Explorer 10 to open in non-compatibility view has accepted an answer that works by defining the default document mode with regard to the <!DOCTYPE> directive. I've tried the registry trick without success. While it may have solved the problem for the other author’s question, my question has to do with X-UA-Compatibile headers.


Picasa Web Albums defines X-UA-Compatible as IE=EmulateIE7. Opening the F12 developer tools and switching document mode from 7 to anything newer (8, 9, 10, Edge) instantly fixes the website. However changes done through the developer tools do not persist.

6
  • Why not open it in Firefox or Chrome? They will always render as the latest browser
    – Ganesh R.
    Apr 19, 2015 at 14:06
  • 3
    @GaneshR. because average users do not want to juggle several browsers. I will always recommend they switch to a non-IE browser, but that doesn’t change my question about Internet Explorer’s document mode behaviour.
    – Martijn
    Apr 19, 2015 at 14:25
  • Possible duplicate, yes, though IE11 was not displaying the compatibility view icon in the address bar in my case. Don’t know if there is a difference between the automatic document mode switch and the website requested one.
    – Martijn
    Apr 19, 2015 at 17:11
  • As for the missing icon: any chance the site's URL has been added to intranet sites?
    – Arjan
    Apr 20, 2015 at 7:16
  • @Arjan, it hasn’t, it was the first thing I checked when Picasa acted up. The list is empty and none of those checkboxes make a difference to the outcome.
    – Martijn
    Apr 20, 2015 at 11:21

1 Answer 1

0

You can assign a persistent Document mode to a site in the user's Internet Explorer by using Enterprise mode site list (Look at the Adding your site to the Enterprise Mode site list section). This is turned off by default, so you need to enable it using Group Policy. Note that this is only available for Windows 8.1, Internet Explorer 11 users.

6
  • This may be a workaround though not the solution to my specific question as it doesn’t specify a document mode locally, it requires a server to distribute a list. Group Policy also isn’t available to me as it does not come with every sub-version of Windows 8.1.
    – Martijn
    Apr 20, 2015 at 11:27
  • You can use a local XML file instead of a server file for the website list, so it doesn't really require a server to distribute a list (though I've not personally tried this so cannot verify). But yes, it is only available in Windows 8.1 pro version. Apr 20, 2015 at 12:20
  • I got the impression from the Microsoft documentation that the enterprise list required the XML file to be served over HTTP. Maybe I misread it.
    – Martijn
    Apr 20, 2015 at 15:55
  • In the 2nd link, they give 3 examples of XML files (in the last few lines of the page), HTTP location, Local network and Local file. Apr 21, 2015 at 5:42
  • I totally missed that, sorry @Chirag64! I will see if this can somehow be activated on non-Pro versions of Windows 8.1 and if it would be able to override X-UA-Compatible values.
    – Martijn
    Apr 21, 2015 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.