I ran into a problem when using my Bluetooth headphones on Windows 7. They support both the A2DP and the Hands-free profile, however it seems that only one of them can be active at a time.

On my other PC, Windows seamlessly switches to the hands-free when a call is received.


In the above image one can see that both profiles are connected, yet only one is active in sound settings.


When A2DP is manually disconnected, the headset profile becomes active.

Any help to how make both profiles switch seamlessly is appreciated.

EDIT: I found a situation how it should look when it works: How it should look

  • Which app are you using for VoIP? In the Communications tab of the Playback Devices window, there is a list of options under "When Windows detects communications activity." Is the selected option ("Mute all other sounds," e.g.) successfully triggered when a VoIP call is initiated? – P Fitz Apr 20 '15 at 12:19
  • Try going to the properties for the headset -> Advanced tab -> uncheck the box for "Allow applications to take exclusive control of this device." – P Fitz Apr 20 '15 at 12:23
  • The switch is not triggered. How it is supposed to work is that both profiles are active, however a voip app (Jabber in my case) should output sound to the handsfree profile. Which takes precedence in the presence of audio input. – Radovan Apr 20 '15 at 13:18
  • The "Bluetooth Headphones" and "Bluetooth Headset" devices in the list shown in the screenshot are in fact the same device, right? If so, try enabling the headphones device and setting it as the default audio device then set the headset as the default communications device. – P Fitz Apr 20 '15 at 13:35

Did you remember to change over the Recording defaults as well as the playback defaults. Bluetooth nice as it is does have a few issues with the newer motherboards especially where unsigned drivers are concerned

  • I did. The problem is that the audio devices are not active at all times. The drivers are Intel and are signed. Perhaps its some limitation of the driver itself. – Radovan Apr 20 '15 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.