1

I created an SFX file (to unzip and launch a program directly) with Winrar which is supposed to be installed in a TEMP folder. I specified to launch "bin/myprogram.exe" after extraction.

When I launch the SFX, I can see that my program is launched but is closed after 0,5 sec. If I go manually to the TEMP folder and launch myself the .exe, verything works very well.

Someone already had the same problem?

My procedure :

I select all the files needed (bin, programData and .ico) New Archive, set to SFX mode. Under SFX Options button, in Advanced tab :

  • Setup : I write bin/myprogram.exe after extraction
  • Mode : Decompress in a tempory file

I tried to unzip in a specified folder or in programFile but nothing changed. Same situation

  • The '\' solved this ! Thanks ! By the way, how to flag my question "Solved" with no responses but only comment ? – Atnaize Apr 20 '15 at 9:28
  • I'll add it as an answer below. :) – Karan Apr 20 '15 at 9:33
0

Since this is Windows, simply use bin\myprogram.exe instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.