1

Today I when I was working with my flash drive (thumb drive) it gave some errors in different OS. Now I can't format it. I tried in MacBook and got this error.

Posix report: the operation couldn't be complete cannot allocate memory

In Windows desktop it asked me to format the flash drive. After that it says it's not possible to format (default setting). I tried formatting it in a virtual machine using Debian via GParted; it says input/output error.

Impossible write partition table (Dos/mbr).

So my question is: Is it possible somehow to get my USB thumb drive working again? or is it dead?

Windows Device Manager says that device is working correctly.

All advise is welcomed.

My device is not so old; it is a Kingston DTSE9H/16GB.

  • what about if reflash controller in usb drive – jcmaxuser Apr 20 '15 at 21:05
  • It's dead Jim... – psusi Apr 21 '15 at 0:10
0

In windows: Uncheck quick format and try again. Try different format like fat and exfat. Try different allocation size. (I suggest default or 16kb) Check if rust or dirt is collected in the port,clean with spirit(flammable) allow time to dry . (Be careful. last resort.)open it and clean Throughly but carefully, with spirit.(when its not connected to anything)

Its better you get another one. If by any means you get to store/transfer data in it, you risk it's corruption.

  • Hey dude, You are real man ! some how but it works it start formating ! – jcmaxuser Apr 21 '15 at 11:22

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.