0

I install all package on virtual machine.I have centos 6.6 and I already installed "mysqld Ver 5.6.24 for Linux on x86_64 (MySQL Community Server (GPL))".I have installed the tuleap on centos 6.6.Sucessfully installed without error.

But when I use:

/usr/share/tuleap-install/setup.sh

I get the following error:

**ERROR** No --mysql-host nor local mysql server installed, exit.
Please install 'mysql-server' package" 

How do I resolve this?

0

By default, the install script only check for mysql-server package from centos 6 base.

To install with another version of mysql, you should start the database and use --mysql-host=localhost as if you installed on a remote machine

  • No I install all package on virtual machine.I have centos 6.6 and I already installed "mysqld Ver 5.6.24 for Linux on x86_64 (MySQL Community Server (GPL))".if I using "/usr/share/tuleap-install/setup.sh" this command,It shows "ERROR No --mysql-host nor local mysql server installed, exit. Please install 'mysql-server' package"...I cant resolve it.help me to solve it.. – Azarudeen S Apr 21 '15 at 11:44
  • As said, the install script rely on mysql-server (v5.1) package to be present. You installed another version (mysqld v 5.6.24), that's perfectly fine but you have to specify that to the install script with --mysql-host – Manuel VACELET Apr 21 '15 at 11:57
  • please let me know how to start Database using --mysql-host=localhost Kindly give me the steps – Azarudeen S Apr 21 '15 at 12:24
0

Well, this error has occured to me and I corrected it by doing as @Manuel said.

Before running the setup.sh I uninstalled the old mysql server I was using. Then I run this command again:

yum install --enablerepo=rpmforge-extras tuleap-all

Which installed the "right" version of mysql-server. After that, you should run this:

/usr/share/tuleap-install/setup.sh --mysql-host=localhost

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.