6

I accidentally configured .data and .text files to be opened with Notepad by default. I want to unlink those extensions from being opened by Notepad. However, Notepad does not appear in the list of files that have an extension linked to it:

enter image description here

In Dutch, Notepad is called "Kladblok", but I don't see that name in the list, nor do I see the icon. I've tried unlinking it using the extensions list, but I cannot figure out how to unlink them via that method either.

I know I can go through the registry, but if AT ALL possible, I'd rather not use that method.

4 Answers 4

10

Actually there is a trick by which you can unlink a file type from its corresponding default program. Its simple and there is no need for a registry edit.

  1. First create a file anywhere in your PC with any name with the .exe extension. For this example lets call it something.exe. (You can create it easily using Notepad. A blank file just save it with .exe extension)
  2. Now select any .data/.text file. Right click on the file go to Open with -> Choose default program. Select "Look for another app on this PC" under More options. Go to something.exe's location and select it.
  3. Now Windows will link the file type with something.exe. All you need to do is now delete this something.exe. When you delete something.exe Windows will have nothing to link the file types to and you will get back your Open with option.
1
  • 1
    Confirmed to work on Windows 7. Probably works on all windows versions.
    – loa_in_
    Aug 24, 2018 at 14:33
1

I don't have enough reputation to comment but I'm posting this in response to @Ayan's answer.

I confirmed @Ayan's trick works on Windows 10 as well, but the procedure slightly differs by the following:

  • You'll select Open with -> Choose another app instead of Open with -> Choose another app

  • You must check "Always use this app to open .data files" after selecting something.exe

  • You can ignore the Windows popup that says "This app can't run on your PC" (don't worry, the trick still works)

0

Try Default Programs Editor, should do the trick, it will edit the registry for You :)

To be more precise, run the app (no installation needed), choose File Type Settings -> click Context Menu -> find your extension -> click Next -> choose Open -> click Edit Selected Command... -> clear the Program path -> click Next -> click Save Context Menu.

You ca find more information with pictures on EightForums.com.

0

If you want to open these extensions with a different program, you can use the following:

  1. Browse to the folder containing a .data or .text file and select the file
  2. Open the "Home" ribbon and click on the down arrow on the right side of "Open"
  3. Select "Choose default program..." and select the program you want to use for the selected file type
  4. Repeat above steps for the other file type

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .