I got a new laptop with 4K screen, but my Photoshop, Illustrator & Dreamweaver have tiny icons instead of the regular size.

I have to scale down my screen resolution to be able to use it properly... Does anyone have a solution for this problem so I can still use 4K? Scaling my screen resolution down messes up my desktop & it's really annoying to do every time I use an Adobe product.

migrated from graphicdesign.stackexchange.com Apr 21 '15 at 14:47

This question came from our site for Graphic Design professionals, students, and enthusiasts.

up vote 7 down vote accepted

John Manly's answer works for Adobe CC as of the 2014 update. Sadly that option doesn't exist in pre-CC and it sounds like Adobe have no plans to fix this.

If you're on CS6 on Windows, there's a hack described here which works on Windows 7 and 8. Warning: it involves hacking the registry, to enable 'external manifests'. See this question regarding possible risks.

Here's the link: http://surfaceproartist.com/blog/2013/12/11/hack-makes-photoshop-and-illustrator-readable-on-surface-pro

It allows you to make AI and PS auto-scale with everything else according to your Control Panel\Appearance and Personalization\Display settings. Be aware, however, that this makes everything, including the appearance of your artwork, slightly grainy as if it was a pixel image that had been scaled up, and that the same Windows scaling applies to Adobe stuff as everything else including web browser etc. After trying every possible combination of settings, for me they all either scaled Adobe too much or everything else too little, or both, and I ended up undoing all of this and simply turning the resolution down one notch. But it might be an option for people with different personal preferences.

Here are the key steps. Before editing the registry, I recommend reading that whole article, and the comments.

  1. Enable Windows to prioritise external manifests by creating and setting this registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest (DWORD) to 1 as mentioned here (no need to install the mentioned hotfix, just create the registry key) http://support.microsoft.com/kb/912949/en-us

  2. Create a Illustrator.exe.manifest file in notepad, paste this text inside, save it, and copy it to the same folder as Illustrator's exe file http://pastebin.com/BZnKwU6a

  3. Create a Photoshop.exe.manifest file in notepad, paste this text inside, save it, and copy it to the same folder as Photoshop's exe file http://pastebin.com/AiZiicT6

  4. Run the applications, no need to restart or anything else, and their interface should now have an acceptable size, but a but blurry as usual with this kind of scaling.

All credit to Rick Rodriguez and the Surface Pro Artist blog.

  • The big problem with all the DPI scaling tricks is that it also scales eg. the editing surface in Photoshop. So sure, you can now see what you're doing, but you're also losing all the benefit of a high-DPI display in the first place. An OK workaround, but a more interesting solution would be some sort of hack that tricks only the UI into a larger size. – gl- Nov 7 '17 at 19:52

I have a 4k monitor as well and this has been driving me insane! The only program that I seem to really have an issue with is PS.

There is an option (Windows only) to scale the UI in PS:

screen

I'm on a Mac, so I can't say for sure what it does, but it might help you.

I did a lot of searching on this subject, when I first got this monitor hooked up and I'm pretty sure that it's a PS bug. As one commenter stated, I've seen lots of complaints, but no solutions.

  • 2
    You beat me to it by a few seconds! I have a high density display on a Windows laptop (3600 x 1800, 15"), and can confirm this solution works for me. – JohnB Apr 21 '15 at 15:40
  • I'm on a mac, so I am just stuck having to work on things zoomed in 200%. Such a stupid thing that I can't believe Adobe still has not addressed yet, to my knowledge anyway. – Manly Apr 21 '15 at 15:41
  • Which version is this option present in? Knowing Adobe it's probably in the latest version of CC only, right? – user568458 Apr 22 '15 at 8:24
  • @user568458 That's the version that I am currently running. I have no idea when it was implemented though. – Manly Apr 22 '15 at 15:07

This was a great solution. I am running Photoshop CS4. I did modify it slightly. I did the following:

  1. Open the Adobe Photoshop folder (Windows C: > Program Files (x86) > Adobe > Adobe Photoshop CS4)
  2. Scroll down until you see Photoshop.exe. Right click.
  3. Select Properties and then the Compatibility tab.
  4. Check the box next to: Override high DPI scaling behavior.
  5. From the dropdown below I selected System.

That was it. It worked great and was simple, without a registry hack.

From this article: Photoshop scaling on high DPI displays

  1. Right click on the Photoshop.exe icon.
  2. Click Compatibility tab.
  3. Uncheck “Disable display scaling on High DPI Settings
  4. Run Photoshop

This also works for other programs with scaling issues.

Here is instructions for older versions of adobe products (before CS6).

Follow the instructions above by user568458 (make sure you can view the file extensions).

If you try to open the program you will get a dll error. Here is how you fix it.

Look in the folder where you placed the manifest you will see a different .manifest file. For photoshop CS4 it's Microsoft.VC80.CRT.manifest.
Open that file, it contains a line which starts

<assemblyIdentity.  

Copy that line into the manifest downloaded from above. Your going to want to replace one of the existing assemblyIdentity lines.

To help illustrate how this is done, here is the photoshop files. You can compare them to the ones above to see how they were modified.

Photoshop CS4 manifest

Microsoft.VC80.CRT.manifest

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.