1

I try to enable WLAN (wireless), it finds my router network, but the password that works for all my other devices doesn't work for the printer. I tried several times, and I know the password is correct.

1

Ensure that the type of wireless encryption you are using is support by the device. Some older devices do not support newer encryption standards like WPA2-AES. Try WPA2-TKIP or WEP(less secure). If those both don't work your only option is ethernet cord or open wifi.

0

I restarted the printer, and it accepted the password. I don't know why.

Before, the printer restarted after switching to wireless, but apparently that was not enough of a restart. xp

tip: afterwards, I ran into an issue of the print job not being sent to the printer. For this, i just downloaded and reinstalled the full software from the website, restarted my computer, and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.