3

The service won't start. I've set it to automatic and manually tried starting it. I've verified any dependencies are started.

  1. I ran net start "Windows Search" and received the error "Service specific error 2147750271"
  2. I ran sfc /scannow and received a ~1MB file of corrupted things that couldn't be repaired.
  3. I attempted to go in to the Indexing Options->Advanced->troubleshooting (it was grayed out)
  4. I attempted to remove the Indexing feature and the Windows Search feature from Add/remove programs and then re-add them after a reboot and that did not work either.
  5. I ran net start trustedinstaller, which succeeded, but the same error message showed up when I tried the sfc again.

Any ideas? I think I should start by fixing the sfc /scannow errors but I'm not sure the best way to do that.The laptop recently had the HD cloned to a SSD (sector size changed) but it has otherwise been working fine.

Thanks for any help!

Edit - Booted to the system recovery partition, ran sfc /scannow /OFFBOOTDIR=C:\ /OFFWINDIR=C:\ and received an error that the "Resource Protection Service" could not start.

3

3 Answers 3

3

From an articled that I downloaded years ago:

Essential first step: disable Window Search service (not stop, but disable).

Reboot

Delete all files in C:\ProgramData\Microsoft\Search\Data\Applications\Windows

Delete all files in C:\ProgramData\Microsoft\Search\Data\Temp

(these are hidden files, so be sure that hidden files are made visible)

Reboot

Start Window Search service (delayed start).

Reboot

(I'm not sure if the last reboots are really necessary, but I did it just in case).

Source: http://www.online-tech-tips.com/computer-tips/how-to-fix-microsoft-windows-search-indexer-stopped-w...

3

On Windows 10

Indexing Options->Advanced->Rebuild (Delete and Rebuild Index).

That actually worked for me in a similar case.

1

I did a repair installation (process detailed here: http://www.sevenforums.com/tutorials/3413-repair-install.html) and this dended up fixing the issue along with some others. I think there were some weird issues when using dd to copy the OS from a smaller block size disk to a larger one; perhaps also from non-ssd to ssd.

Not the answer you're looking for? Browse other questions tagged or ask your own question.