13

My Task Manager only shows up in the screen connected with VGA and clicking "Only show tasks from the current screen" in Task Manager Settings doesn't make the Task Manager bar appear on the second screen.

Setup:

  • I have two identical Philips screens.
  • I have a HP laptop sitting in a HP docking station. The docking station has one DVI and one VGA port.
  • One screen is attached via VGA cable, the other via DVI cable.
  • Both screens work and I can drag windows between the two and they are using
  • The DVI screen shows up as HDMI2
  • The laptop lid/screen is closed (and I want to keep it that way)
32

You need to add a new panel to the second screen, and add a task manager to that.

Right-click on the background of the second screen -> Add Panel -> Empty Panel.

If you know how to move panels and add widgets to the panel, then move the panel to where you want it, add the tasks widgets, then set it to also only show widgets from the current screen.

If you don't know, then read on:

Right-click on the panel -> Panel Settings then drag the Screen Edge bar to the bottom of the screen to move the panel. Then right click on the panel -> Add Widgets -> Double-click on Task Manager. Then right-click somewhere near the middle of the panel -> Task Manager Settings -> Only show tasks from the current screen

  • 1
    AMAZING ANSWER! – Mark van Wyk Oct 1 '16 at 15:27
  • 1
    I don't like this as you will end with two different bars. The bar sould be just one to be display on the main monitor. – EnzoR Dec 14 '16 at 7:56
  • 1
    @Enzo: You can remove the original bar. – TheBlackCat Dec 30 '16 at 17:43
1

Right click on the taskbar, unlock graphical components.

Now right click again on an empty area in the taskbar, and choose "dashboard options", then "dashboard settings". This will open an extra bar with a choice called "screen side".

Now click on that button and drag to the side where you want the taskbar to be: you are not limited to the current monitor, so you can move it to the other monitor. When you're done, click the "close" red checkbox.

Note: I'm using a french version of KDE so the names may not be the exact ones you'll see, but should give you the general idea. Feel free to suggest edits for english versions.

0

Admittedly I found that the following worked as I followed the recommendation in FGM's answer, but it is also different enough that a separate answer seems appropriate. I am using KDE Plasma with a two screen set up, and the taskbar appeared at the bottom of the right screen by default. However, I prefer it at the bottom of the left screen and came here for a solution (via my favorite search engine). Based on my experiences, this will (hopefully) work for others:

  • Right click on an empty part of the taskbar; that should reveal a menu.
  • Left click "Panel Options", which will reveal another menu.
  • Left click "Panel Settings", which will present a new area above the taskbar with several options.
  • Left click and hold "Screen Edge" and drag the taskbar to the other screen; note that as you drag it from one screen to the other the taskbar may try to affix itself to the sides of the screen - just keep dragging to get it to where you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.