1

We're running Windows 8.1 with the current stable Firefox and IE. There's a fresh installation of Apache 2.2 that has been enabled to do SSL.

  • http://localhost is reachable in Firefox and IE and serves a website
  • http://localhost:443 is reachable in Firefox and IE and serves a server error saying something like "go away, you're not encrypted"
  • https://localhost is reachable in IE and serves a website, after accepting the custom untrusted certificate

https://localhost is not reachable in Firefox. It shows a Firefox screen that it cannot resolve the address. The same happens to https://127.0.0.1 as well as the computer's IPv4 address on its regular network interface.

We've tried clearing the browser cache, flushing Windows' DNS cache and rebooting (several times).

Even after directly hitting the site in IE with https enabled, Firefox does not load anything.

I have not tried any other browsers so far.

Why is this happening and how can I fix it?

  • Firefox uses its own certificate store. So Firefox is rejecting the secure connection since the certificate from its perspective isn't valid. – Ramhound Apr 24 '15 at 16:28
  • 2
    I'm surprised http://localhost:443 (unsecured HTTP over port 443) works at all. It almost sounds like you have standard HTTP bound to port 443 somehow. I tried that on an Apache site or two that have SSL running properly, and I just get a blank page in IE rather than content or a security warning. Chrome and Firefox give a warning that I'm trying to talk HTTP on an HTTPS port. Does https://localhost:80 give you different results? – GuitarPicker Apr 24 '15 at 16:36
1

As it turns out, all we needed to do was add the certificate manually to Firefox's certificate store as an exception. The weird part is just that it didn't ask to do that, but instead behaved like it could not connect. Usually it should show the "get me out of here" page.

  • 1
    had the same error and you're right. Internet Explorer ("Edge") shows error but works. Firefox redirects to localhost.com. Adding it as a manual exception helped me too – BlueWizard Sep 7 '16 at 8:44
  • 1
    Would you care to explain the steps you did in order to manually add the certificates? Thanks – BringBackCommodore64 Mar 16 '18 at 18:24
  • @BringBackCommodore64 I'm afraid I don't have that computer any more, and I don't remember. You should be able to find a video on YouTube that explains this. That's probably what I did, too. – simbabque Mar 17 '18 at 0:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.