0

I have a WD Element 1TB external hard Disk and suddenly I got some errors in data reading and writing. I decided to recover it, and I tried to do so many ways and nothing worked. I tried to run chkdsk, but it keeps getting stuck at about the same spot. I tried to do some surface tests too, but everything failed. I then decided to clone the disk. I used Acronis WD version of cloning and clonezilla, but they both failed.

Failed to prepare operations. Error code: 10 'File system error is found' with extended code: 458,776 'MFT bitmap corrupted'

This is what I got in the event log. Is there anyway I can recover my HDD?

  • Time to grab your backup & restore to a new drive - that one is dying fast. – Tetsujin Apr 24 '15 at 18:32
  • Thanks for every ones help. Finally I did it using Active File Recovery Professional. That is the only one worked for my situation. – wajira000 Dec 10 '15 at 9:05
1

You might have better luck using a program like GNU ddrescue in Linux, it can try skipping over the bad "sticking" sectors and keep reading beyond them, recovering more of your data.

I would stick to read-only operations until you have at least a copy of everything that's currently readable, even if there are corrupted sectors in your copy. Further write attempts on the hard drive could result in further/faster corruption/damage.

These Q's might be helpful too:

0

Unfortunately when a HD begins to gradually fail the data loss is often irrecoverable and can become catastrophic. Backing up a HD with bad sectors seldom works as the data in those sectors is still lost. There are tools that claim to do it but, good luck.

0

For recovering data from dying or formatted drive I would recommend use of R-Studio http://www.r-studio.com/Data_Recovery_Download.shtml

The best thing about this program is that it is capable of restoring files even when Partitioning data is damaged.

But this tool is not for free. The basic version which should be enough for you costs $80

0

Thanks for every ones suggestions. Finally I did it I used Active File Recovery Professional. It can recover data much as possible. I tried dozen of software some of them are top recovery tools and everything fail. Using Active recovery I manage to create image of failed disk and mount it and recover the data but the problem with that is naming. All file name change to something their naming convention and files are separate by file type like video, jpg and it took 2 days. Later I found option recovery in the menu and simply I could recover everything as it is with the folder structure. I had very few data lost

-1

Follow the steps below

  1. Please check all the disks for errors by the means of the CHKDSK utility:
  2. Go to the Command Prompt (Start -> Run -> cmd);
  3. Enter the command: chkdsk DISK: /r
  4. where DISK is the drive letter of the partition you need to check.

Notes:

  • Checking the C: drive may require you to reboot the machine.

If the issue still persists, it is recommended to install the latest updated SnapAPI driver:

  1. Download, unpack and install the SnapAPI1088

  2. Reboot the machine

  • I already tried chec disk and I mentioned it above it failed – wajira000 Apr 24 '15 at 17:52
  • Try to install the latest SnapAPI driver. – vembutech Apr 24 '15 at 18:07
  • Bad advice. When the drive is at the point of catastrophic failure there's no time to be wasted and running chkdsk will only push it over the edge. @wajira000: You've already tried running surface scans so it can't be helped, otherwise that's never a good idea. The priority should always be to stop any and all write operations and get as much data as possible off the drive ASAP before it fails completely. – Karan Apr 25 '15 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.