1

I'm using Thunderbird along with my GMail account. I didn't find it very user-friendly, because I have to do things twice. For example, when I receive a mail, I have to delete or mark as read it both in GMail and Thunderbird. Doing so in only one of them doesn't affect the other.

I want Thunderbird to behave like this:

  • When I delete a message in Thunderbird, it must also be deleted in GMail.
  • When I delete a message in GMail, it must also be deleted in Thunderbird.
  • When I read a message in Thunderbird, it must also be marked as read in GMail.
  • When I read a message in GMail, it must also be marked as read in Thunderbird.
  • If a message is filtered by a GMail filter to skip inbox (not shown in inbox and directly transferred to a label), Thunderbird mustn't display it either.

How do I make them work in parallel, so that doing things in one of them will suffice. Thunderbird must apply changes on it to GMail, and it must check GMail to keep itself up to date.

You may suggest an extension if this can't be done with Thunderbird alone.

  • sounds like you set your account up using POP. You need to use IMAP. ANY mail client worth their salt should support both. In fact, I'm surprised IMAP isn't working right now. It's the default. – Russell Uhl Apr 24 '15 at 20:11
  • You can turn off POP/IMAP support on Gmail (and I think they are both off by default). And for the capability that you want, then as @RussellUhl said, configure your Thunderbird using IMAP. – Darius Apr 24 '15 at 20:18
  • @Darius good call on the default gmail settings. I forgot it was disabled by default. – Russell Uhl Apr 24 '15 at 20:26
2

This smells like POP3 to me. When using POP, all mails and folders are downloaded from the server and onto your machine and handled locally. The result is that any action taken through one client (for example, gmails web interface) will not be duplicated to the other client (in your case, Thunderbird).

What you need is IMAP - All files and folders are stored/handled on the server, and the clients merely sync towards this.

When setting up the account in thunderbird, make sure you select IMAP as opposed to POP3.

You may also have to set this in your gmail account:

  • Settings
  • Forwarding and POP/IMAP
  • IMAP Access
  • Check "Enable IMAP"

....that's what I have, and I do not know if this is the default or if I changed it.

  • I eneabled IMAP in GMail settings and changed Thunderbird connection settings to IMAP. I'm waiting for new mails to arrive. I will test this new configuration for a while and return here to report the result. – hkBattousai Apr 24 '15 at 20:27
  • @hkBattousai If you haven't already done so, you may want to delete the account in your Thunderbird, to ensure that any stored mails/folders are copied over. An IMAP sync should re-download everything anyway. – Jarmund Apr 24 '15 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.