9

I have Lubuntu running on VirtualBox properly.

I followed the same procedure for installing CentOS 7 on VirtualBox. However, once I see the CentOS installation menu, I click on "Install CentOS", and then black screen shows up!

Again, once I click on "install CentOS 7", I see "black screen", that`s it.

Note that I am aware to the fact that CentOS 7 is 64 bit, so I enabled virtualization in BIOS in advance.

I tried Minimal ISO CentOS and DVD ISO CentOS, but both causes black screen to appear.

I even clicked on troubleshooting option in the installation menu, which gives an option to install CentOS 7 in 'basic graphic mode' but I still get black screen.

What ever I try, I can`t install CentOS 7 on Virtualbox (4.3.26 - Latest edition).

2
  • Are you even seeing the boot screen or Centos installation screen? – EternalHour Apr 27 '15 at 9:06
  • I just have CentOS intallation screen. Finally some one replies! I dont see any boot screen. I just see CentOS Installation menu -> I press enter on "install CentOS 7" and then black screen. Thats it! Can you please assist? – Qwerty Apr 27 '15 at 10:16
14

Solution is to set the Linux version in VirtualBox to be 64 bit!

1
  • 1
    How do I do this? – WendyG Dec 18 '18 at 16:11
2

Hopefully the below links help on 'how to change virtualbox to 64bit, if you do not see any 64bit option in the dropdown menu

{http://www.fixedbyvonnie.com/2014/11/virtualbox-showing-32-bit-guest-versions-64-bit-host-os/#.WCswkrKLRpg}

I followed the steps and it worked for me!

Edit: The problem the link says is that you have Hyper-V installed. Remove roles and features > uncheck hyper-v > wait for wizard to finish > reboot

Try the menu now and you should see 64-bit.

2
  • 2
    Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Nov 15 '16 at 17:30
  • Thanks man, Disabling Hyper-V worked for me. – Muhammed Ozdogan Jan 6 at 8:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.