0

I want to access a remote LAN network, without using this remote Internet connection when I browse websites for example.

What I have so far is a working VPN connection (PPTP) but when I connect to it, it uses the remote Internet connection for everything. I tried disabling the "Use default gateway on remote network" in the connection properties on the client, but then I can't access the remote local network anymore.

The router on the remote network is an Asus RT-AC66U. The only VPN settings available (to my knowledge) look like this: http://event.asus.com/2012/nw/dummy_ui/en/Advanced_PPTPAdvanced_Content.html

All the VPN clients are on Windows 8.1.

What can I do? Is what I want even possible with a router like this?

Edit: the route table on the client look like this:

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0      192.168.1.1     192.168.1.25   4235
          0.0.0.0          0.0.0.0         On-link      192.168.10.2     11
        127.0.0.0        255.0.0.0         On-link         127.0.0.1   4531
        127.0.0.1  255.255.255.255         On-link         127.0.0.1   4531
  127.255.255.255  255.255.255.255         On-link         127.0.0.1   4531
      192.168.1.0    255.255.255.0         On-link      192.168.1.25   4491
     192.168.1.25  255.255.255.255         On-link      192.168.1.25   4491
    192.168.1.255  255.255.255.255         On-link      192.168.1.25   4491
     192.168.10.2  255.255.255.255         On-link      192.168.10.2    266
   REMOTE IP ADDR  255.255.255.255      192.168.1.1     192.168.1.25   4236
        224.0.0.0        240.0.0.0         On-link         127.0.0.1   4531
        224.0.0.0        240.0.0.0         On-link      192.168.1.25   4491
        224.0.0.0        240.0.0.0         On-link      192.168.10.2     11
  255.255.255.255  255.255.255.255         On-link         127.0.0.1   4531
  255.255.255.255  255.255.255.255         On-link      192.168.1.25   4491
  255.255.255.255  255.255.255.255         On-link      192.168.10.2    266
===========================================================================

The network 192.168.1.0 is the local network, 192.168.10.2 is the VPN, 192.168.2.0 is the remote local network (although there is no mention of it here).

Can I manually edit these routes in a way that would work for me?

3

I found a solution by changing the client side only. In the table above, the route

0.0.0.0    0.0.0.0    On-link    192.168.10.2

sends everything through the VPN.

If I uncheck the option "Use default gateway on remote network" (on the VPN connection, right click Properties -> Networking -> IP V4 -> Properties -> Advanced), this route disappears: nothing goes through the VPN anymore.

If I then manually add this route instead:

192.168.2.0    255.255.255.0    On-link    192.168.10.2

It starts to send local network traffic through the VPN again (but only that), so everything works as I expected.

Here is the command line to add this route, in case it can help somebody else (needs to be admin):

route add 192.168.2.0 mask 255.255.255.0 192.168.10.2

Edit: And this one does the same for broadcast, if needed:

route add 192.168.2.255 mask 255.255.255.255 192.168.10.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.