29

I load up GIMP and it gets stuck on "Loading Data Files: Fonts" every time.

  • I have deleted my GIMP profile multiple times, I cleared my font cache, I even searched for corrupt fonts, (0kb font file size) there were none.
  • I haven't installed any extra fonts that I can remember.
  • I did have a previous version of GIMP before, but I uninstalled it.

System Specs:

  • Win 7 64-bit
  • i7-2670QM
  • 8GB RAM
  • Anything in Event Viewer > Applications regarding the issue? – EternalHour Apr 27 '15 at 21:43
  • Not that I can see, but I've never used Event Viewer before. – GusN Apr 27 '15 at 21:49
  • How long do you wait before deciding it's stuck – BJ292 Apr 27 '15 at 21:56
  • I have waited 30 minutes before, but the window is always unresponsive right after it gets stuck on loading fonts. – GusN Apr 27 '15 at 21:58
  • 2
    I'm having this same issue on the latest Mac OS X. Looks like this might just be a GIMP issue. – CGTheLegend Apr 12 '16 at 7:26
8

This step can take a long time. And due to the way file timestamps are handled, it can e.g. happen on daylight saving time switches.

In order to check what exactly is happening there, you should use a file access monitor like Process Monitor - https://technet.microsoft.com/en-us/library/bb896645.aspx.

This can tell you if GIMP is reading font file to build the font cache, and will also provide you with some sort of progress information, because the font files will be mostly accessed in alphabetical order (or reverse).

The unresponsive window is a symptom of that, just ignore it.

  • 24
    This slowness is making gimp seem bloated to any new user and users of portable gimp. Does anybody know what "loading fonts" actually mean? Is it rendering thumbnails or is something else making it take forever? Would it make sense to request this process is moved to happen after gimp is loaded in less priority threads, with placeholder thumbnails? Or has it been reported already to no avail? – qubodup Apr 4 '16 at 20:21
  • 1
    fontconfig reads all the font files to create the font cache. Traditionally, many changes to Free Software happen because a user affected by an issue or lacking a feature tackles the task. So far, this hasn't happened here - probably because it mostly affects the Windows platforms,where the developer-to-user ratio seems to be very low. The issue is reported, and someone from the user base stepping up to investigate the underlying technical reasons would be a very well received change. – Michael Schumacher Apr 5 '16 at 10:49
  • 1
    Thanks, it looks like this is the commit: git.gnome.org/browse/gimp/commit/… – qubodup May 3 '16 at 21:46
  • 2
    It will not fix the long wait, though. – Michael Schumacher May 4 '16 at 5:50
  • 9
    This takes forever on OSX too. Why is this needed? I don't even use fonts, I just want to edit pictures. – user985366 Nov 13 '17 at 18:12
10

Even the latest Windows version 2.8.22 has this problem.

Go into Preferences -> Folders -> Fonts and delete all folders listed there.

GIMP has a couple user font folders listed there by default, for some reason on Windows those folders make the font loading part really slow, like 15-30 seconds even on SSD. Now GIMP loads in a few seconds on SSD.

Hope this helps.

  • 1
    This worked for me on Windows 10. I tried other suggestions and I thought I was going to have to live with the long loading time forever. – Sys_Admin_Luddite Mar 18 '18 at 21:39
  • I think the first restart of GIMP, it rebuilds the font cache, but then on the next one its fast again. – RowanC Apr 30 '18 at 4:11
  • This fixed the long wait for me. It was happening on a OSX High Sierra and deleting those two folders from the preferences changed the startup time from > 3 minutes to under 5 seconds. – RayB Jun 22 '18 at 22:20
8

The following steps worked for GIMP 2.8.20 on my Mac (Sierra 10.12.6):

  1. Open GIMP
  2. Click the upper left GIMP icon and choose “Preferences”
  3. Go to “Folders” → “Fonts”
  4. Delete all folders listed there (the delete button looks weird; it should be the fourth icon counting from left)
  5. Click “OK” to close the dialog box
  6. Close GIMP and reopen it
  • Edit / Preferences in Windows version. It takes as long to delete those folders and re opening Gimp the first time after doing this (take a lo00ong time). After that, it loads fast again! – Metafaniel May 18 '18 at 15:56
  • 1
    Delete button does look weird, I think it's a paper shredder. Solution works perfectly though, GIMP is nog starting in seconds instead of minutes. – Wietse Sep 10 '18 at 9:24
3

Go to Gimp folder. Create a shortcut from GIMPPortable.exe or GIMP.exe. Go to properties of your new shortcut. And in the Target field at the end add " -f" like this

D:\Progs\GIMPPortable\GIMPPortable.exe -f 

Have a nice painting )

Addition:

GIMP comes with a so-called batch mode that allows you to do image processing from the command line. See gimp --help

-f, --no-fonts          Do not load any fonts

For more information look GIMP Batch mode

  • What does this actually do? – Clonkex Apr 20 '18 at 1:36
  • This executes GIMP without loading fonts, you just need to execute GIMP with parameter (-f) – KonchenayaTvar Apr 21 '18 at 12:30
  • On mac the command is /Applications/GIMP.app/Contents/MacOS/GIMP-bin -f – gerrytan Apr 30 '18 at 5:37
  • Actually I don't think the -f option is useful. Although gimp load, now I can't open jpeg file :( – gerrytan Apr 30 '18 at 6:20
  • I think Jpeg is not connected with fonts. Try to open Jpeg file in other editor and resave. For me always help to open trouble jpeg file in Windows Painter and just resave it. And OMG, it opens. – KonchenayaTvar May 1 '18 at 6:45
-1

From this superuser answer
This worked for me.
First:delete the font folders.
Second:close gimp.
Third:open gimp.
Fourth:close gimp.
Fifth:this time when you open gimp, there will be no 'looking for fonts' process.

  • 1
    Confirming: two restarts of Gimp were needed in my case too. – Daddy32 Jan 29 '18 at 13:09
  • Don't reply to answers with new answers. This should be a comment on the linked answer. – Clonkex Apr 20 '18 at 1:36

protected by Community Aug 5 '18 at 14:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.