0

Using GIMP on Mac OS X (10.9.4), copying part of an image using the select tool ends up copying the whole image instead.

I've selected the part of the image I want to copy with the Rectangle Select Tool. Then I copy it (so far so good). But when I paste it, and then try to move it around, the original image is moved around instead, not the part I want to copy. So it's either copying the whole image or not even copying correctly in the first place.

I've tried both with the main GIMP distribution and the GIMP on Mac OS X version.

Any ideas?

  • Can you actually move the selection? After selecting, with the cursor inside the selection, the cursor should change to the move cursor (4 arrows). You can then drag the selection around. Does that work? If not, you might have the 'Pixel lock' on. – jcoppens Apr 27 '15 at 22:01
  • I can move the selection itself around, but not the content that's been selected. Neither of the two lock buttons appear to be on. (I just tried switching them on/off, no effect.) :/ – AmadeusDrZaius Apr 27 '15 at 22:03
  • You have only one layer in the image, correct? And didn't first add a new layer, before selecting? – jcoppens Apr 27 '15 at 22:16
0

This was located at the GIMP docs website.

"hold down Ctrl+Alt keys and click-and-drag the selection. This makes the original place empty. A floating selection is created. The required key commands may differ on your system, look in the status bar to see if another combination is specified; for example, Shift+Ctrl+Alt."

  • This has to do with floating a selection and moving its contents, without the need for copying or pasting. – jsbueno Apr 28 '15 at 20:13
  • the question was about osx – 2xMax Nov 7 '18 at 19:55
0

It is likely your options for the Rectangle selection tool are stuck in some mode other than "Replace the current selection" (and since tool options are store per user, they might be surviving program re-installs).

Just check in the tool options for the the rectangle selection tool (double click the rectangle selection icon if the tool options is not visible),a nd ensure the very first option there "Mode" is set to "Replace the current selection".

There is another way to further check what is going on (and you might need if the problem persists) - after performing "paste" check the Layers dialog (hit ctrl + L if it is not visible), and certify yourself you have both a "background" layer and a "Floating selection" there.

Another cause of your problem might be that you are for some motive consistently anchoring the floating selection after performing the Paste. (for that to happen, one just have to click on the image outside the pasted area). To avoid that, before trying any action on the image, after pasting, select the command Layer->To New Layer from the menus: that will promote the pasted contents to a full layer that can't be "melded back to the bacjground" by chance. (again, watch the Layer's dialog to better understand what is going on)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.