0

This question already has an answer here:

I use MS Office 2010. While using Excel, whenever I type 1 A, 2 A, 3 A up to 12 A and move to next cell by hitting Tab or Enter key it automatically becomes 1:00 AM, 2:00 AM.....12:00 AM. This problem is not there when I type 13 A, it is only up to 12 A.

The same problem is there when I type 1 P, 2 P up to 12 P. It becomes 1:00 PM, 2:00 PM.......12:00 PM. There is no problem for numbers larger than 12.

Why this happens ? How can I stop this ?

marked as duplicate by Jason C, fixer1234, Karan, DavidPostill, Wes Sayeed Apr 28 '15 at 14:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

Excel is changing what you type "1 A" to "1:00 AM" because the programmers believe that most people would want the time if they put "1 A" into a cell. So entries between 1 and 12 with an A or P gets converted into a time.

To stop this, you can either disable auto-correct (I will need to look up the commands), or you can format the cell as text before you enter the data.

Added:
It may also be possible to undo the auto-correct by pressing Ctrl-z.

2

It's because it's using the default formatting and detecting a time.

Before entering the data, select the cells then change the formatting to text (right click the cells and choose "Format...").

Not the answer you're looking for? Browse other questions tagged or ask your own question.