6

Just got switched over to "Skype for Business" today. I have a standing meeting with an external client that I connect using a standard Lync meeting url: https://meet.TheirInHostName.com/FirstName.LastName/SoMeUnIqUeCoDe

Normally I go to the meeting by clicking on bookmark I have of the url, and a page pops up saying it's connective via Lync, while my Lync client starts to connect to the meeting. Now that I don't have Lync, it gives me the Lync Web App page:

Lync Web App

But, if I paste the link into Internet Explorer, Skype for Business opens correctly.

How do I get Chrome to do what IE does? Attempting to install the Lync Web App Plugin doesn't seem to work.

8
  • Have you tried creating a new meeting url and trying that? You should be able to this internally shouldn't need an external client to do it.
    – Ramhound
    Apr 28 '15 at 14:09
  • @Ramhound, it's their meeting url. I can't create a new one.
    – Daryl
    Apr 28 '15 at 14:10
  • Yes; I understand that. You should be able to create a meeting url with yourself as a test. One of two things is going one. I suspect the plugin just as to be updated.
    – Ramhound
    Apr 28 '15 at 14:15
  • @Ramhound the Lync Web App plugin?
    – Daryl
    Apr 28 '15 at 14:17
  • Yes; I suspect the incapability with Chrome is because the plugin has not been updated to support Skype for Business. Have you verified there isn't a "Skype for Business Web App" plugin that perhaps was released?
    – Ramhound
    Apr 28 '15 at 14:19
5

I stumbled upon this today my self in our organisation and had to Enable NPAPI in the Chrome browser.

The reason for this is because April the 14th Chrome update disabled this plugin by default. TechNet Blog

To do this, follow these steps:

Enter the following URL into the Chrome address bar:

  1. Chrome://Flags/#enable-npapi
  2. Click the Enable link to enable NPAPI support.
  3. Restart the browser.
  4. Click the meeting invitation link.
  5. Enable the plugin for the meeting join domain by using the dialog box that follows the plugin warning message.

Note This step is required for each unique meeting join domain, depending on the company that hosts the meeting.

This is taken from Microsoft KB 3057679 Hope this helps you to as it did for us.

3
  • 1
    I wouldn't have never thought the plugin was NPAPI . The good news its very likely the plugin will be updated. This workaround will only work until September 2015, so if you must use this plugin at that point, disable Chrome updates by the end of Aug.
    – Ramhound
    Apr 28 '15 at 14:45
  • Any new solutions to this? It's back to not working :/ Sep 9 '15 at 14:54
  • @JohnBustos I know it's not via Chrome but you can join the meeting via the Skype for Business (Lync) program on your computer. Open the program and little icon that looks like a calendar, from there you can join the meeting. link
    – Datmocc
    Feb 10 '16 at 6:56
3

NPAPI support in Chrome is now long gone, so we need to try an old browser like Internet Explorer. If pasting the meeting link into IE opens the meeting in the Skype/Lync client, then try this:

  1. Install 'IE Tab' from the chrome store. https://chrome.google.com/webstore/detail/ie-tab/hehijbfgiekmjfkfjpbkbammjbdenadd
  2. Go to 'IE Tab' options and in the Auto URLs section, add the beginning part of your meeting url like this and add a * at the end: https://lync.companyname.com/*

Now when you click a meeting link, it'll first open it in chrome, but then will redirect the link to IE.

2

You can also join the meetings directly from Lync, without the need for a web browser. Try the command

"C:\Program Files (x86)\Microsoft Office\Office15\lync.exe" conf:sip:https://meet.theirinhostname.com/FirstName.LastName/SoMeUnIqUeCoDe

You can make a desktop shortcut for it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.