3

I have an MSI GT602OC Laptop upon which I'm using an Ubuntu 15.04 (only OS). I can access my OS, it boots fine, no problems here.

But when I try to access the BIOS (through the DEL key that I used many times before) I get a blank screen (with a cursor that doesn't even blink) and it hangs on undefinitely. I tried to press any other key, but nothing happens. All I can do is shutdown my computer via the power button.

Here are some information about my BIOS:

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: American Megatrends Inc.
        Version: E16F4IMS.50P
        Release Date: 12/25/2013
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 3072 kB
        Characteristics:
                PCI is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                EDD is supported
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 4.6

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: Micro-Star International Co., Ltd.
        Product Name: GT60 2OC/2OD
        Version: REV:0.C
        Serial Number: FFFFFFFF
        UUID: 00000000-0000-0000-0000-448A5B41507E
        Wake-up Type: Power Switch

Additional information:

  • I tried to reset CMOS, but nothing changed.
  • When I boot with no devices attached (no HDD, no DVD, no USB, etc) I get a this sequence of messages: a) "No media present", b) "Launching system setup", c)the screen goes black with a non-blinking cursor and hangs on there indefinitely. The same thing happens when I choose the "System Setup" entry from the GRUB menu.

Update:

The BIOS is there, since the clock shows the exact date and time even with no internet synchronisation. I know it's there, it's just that I can't access the settings window.

9
  • Have you tried attaching an external monitor to see if the bios is confused about the video display?
    – jdh
    Apr 28, 2015 at 14:43
  • I didn't attach any external monitor to my laptop since I bought it. I don't have an external monitor to try with. Apr 28, 2015 at 14:53
  • ... or maybe your montior is connected to a video card in your computer and the BIOS is showing on the motherboard's video output? In some notebooks, there are actually two video cards, too. But I wouldn't know how to switch there.
    – jcoppens
    Apr 28, 2015 at 14:53
  • 1
    And, on another note: MSI seems to be aware of BIOS issues and seem to recommend updating: forum-en.msi.com/index.php?topic=252246.0
    – jcoppens
    Apr 28, 2015 at 15:04
  • Thanks for trying to help. I checked that post. And unfortunately my BIOS version doesn't support flashing from DOS. So even if I install Windows, I would still not be able to update the BIOS from there. I'm going to do a blind flash (here is the post: forum.techinferno.com/msi/1839-msi-g-series-unlocked-bios.html) and I'll see. Apr 28, 2015 at 15:15

3 Answers 3

1

Sometimes it helps to create a "Stuck key" situation.
Keep an arbitrary key pressed while the laptop boots.
It will think the keyboard is faulty and give an erro-message about that. Then it may allow you to get into the bios. ("Press F1 to continue, F2 for Bios setup" or something to that effect.)

3
  • No need for that. In the grub menu I can choose the "System Setup" entry to access my BIOS. But now, when I choose this entry the screen goes black with a non-blinking cursor and hangs on there. Apr 30, 2015 at 15:22
  • @addictcook Getting into the BIOS via grub is NOT, I repeat NOT, the same as entering the BIOS directly on boot. And the grub method may actually be the cause of the problem in the first place. It is not guaranteed to work. Some BIOSses, particularly on laptops, don't like being activated via grub at all or work only with a specific version of grub.
    – Tonny
    Apr 30, 2015 at 16:12
  • This is understandable but I used to access my BIOS through GRUB before. Anyway, I tried to simulate the stuck-key situation with my DEL key: nothing new happened. May 1, 2015 at 6:10
0

Try reflashing your BIOS or flash an earlier Version.

Edit: Do not use a modded BIOS Rom file!! Search on your manufacturers site instead.

0
0

I have an MSI GT602PE dominator pro 3K Laptop. There is few days I had the same issue. I can use my computer with Ubuntu 14.04 or Windows 10. Here no problem! But it was impossible to access to the Bios menu. When I press the DEL button I get a blank screen (with a cursor that doesn't even blink) and it hangs. I suppose you have also a raid 0 with 2 SSD drive (exactly as my GT60 msi laptop). My solution was to open the laptop and physically remove the SSD drives. After that I was able to access to the bios menu. Therefore, you can save and exit. You shutdown again the laptop and you reconnect the 2 SSD drives. And now everything works for me :)

3
  • I solved the problem by doing a blind flash. First I downloaded the flash that corresponds to my BIOS version from the official website of MSI. I extracted the files and renamed the image file to AMIBOOT.ROM. I copied then the renamed file to a bootable FAT32 usb stick. I shutdown the computer completely and started again. Once the power button pressed, I pressed the Ctrl+Shift+7 combination. The screen turned black for 30 seconds then the computer rebooted automatically. Next I heard my Turbo Fan for arround 40 seconds, then the Laptop rebooted again automatically. And bingo you're done. May 7, 2016 at 22:02
  • This appears to be a comment not an answer to the author's question. You don't explain, in detail, how to solve the author's problem.
    – Ramhound
    May 16, 2016 at 16:25
  • I donno, removing the SSDs does sound like a solution -. It does seem duplicated and the OP said it didn't work. OP should post a detailed answer himself tho - the comment he posted here is something that would work as an answer.
    – Journeyman Geek
    May 17, 2016 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.