0

Question

I have x11vnc setup on a Xubuntu 14.04 machine, however when I connect to the local session, no keyboard or mouse access is accepted.

I start x11vnc using:

x11vnc -xkb -forever -shared -bg -rfbauth /home/ted/.x11vncpass -display :0

(I also tried -noxrecord -noxfixes -noxdamage -xrandr resize)

So how do I get keyboard input over vnc working on xubuntu 14.04?

What I tried (Rant & links to some solutions for vnc and Xubuntu)

I am running Xubuntu, because I liked it for its relatively light weight and ease of use. However recently I tried to setup remote desktop access.

First I tried nomachine, then I found this bug. So I switched to vino. First of all I had to fix the keymap, by downloading a correct one (apparently VNC needs a mapping of its own AND the correct mapping is not supplied with the package). Then I had to fix Xubuntu's key-configuration to allow remote tab completion. Later I encountered trouble starting vino over ssh, since I could not find the source I switched to x11vnc, now I can start the vnc server and connect to it. However while in new sessions I can use my keyboard, I can't start qtcreator, since XRandr and XKeyboard fail to work in the vnc session, and the driver swrast (what ever that is for) can't load. If I try to reuse the session I started at the desktop, I see the qtcreator which I left running, however neither my keyboard, nor my mouse work. I found that this might be related to lightdm (in particular comment 9).

I tried X-forwarding, but that is too slow/sluggish.

Since I want to access my machine without installing extra programs on friends computers, I also run xrdp to make the sessions available through windows remote desktop program.

0

Are you using FreeNX? Afaik neither NoMachine or NX 3.5.0 can coexist with FreeNX on the same machine, they are different products. Be sure to uninstall FreeNX and try again.

  • No I am not using FreeNX. And nomachine is out due to the bug I linked to in my question (does not work with xubuntu 14.04 if the lock screen is running). The No keyboard issue is with x11vnc. – ted May 6 '15 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.