0

specs: OS - Ubuntu 15.04 (64-bit) and Matlab - ver. R2013a (64-bit)

I have successfully installed and activated Matlab. After trying to run it via terminal, it is showing error on the terminal.

Warning: Unable to load Java Runtime Environment: libjvm.so: cannot open shared object file: No such file or directory

Warning: Disabling Java support Warning: latest version of matlab app-defaults file not found. Contact your system administrator to have this file installed.

Disabling Java support Warning: MATLAB Toolbox Path Cache is out of date and is not being used. Type 'help toolbox_path_cache' for more info

Previously, I first installed Java 7 and jdk both, but it came out with same error. I thought it to be a mismatch between Java installed and Java resources pre-packaged in Matlab Installation media. So, I did a fresh install of Ubuntu & Matlab, both.

But still the same error on running Matlab.

Now, I don't have Java installed on my system. should I install it?

I don't want to leave Ubuntu. Please advise.

0

the JRE is part of the JDK install only the JRE if that is all that is sufficient for your needs but imo the jdk is best option....if still getting errors run locate -i libjvm and see if it does exist (even if misplaced) and if misplaced symlink it to the proper place and retry.

1
  • I located it;it is in the usual location: <matlab directory>/sys/java/jre/glnxa64/jre/lib/amd64/server
    – a.s.
    Apr 29 '15 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.