1

I just got a new HP Probook 450 G2. One of the tasks I got it for, was to use Google Docs and google scripts. I've noticed when using Google script editor, on Chrome and Firefox,

My fonts are not looking right. The tops of the letters are funny. The equals sign is darker at the top than the bottom. I've had a play with font and cleartype settings and can't fix it.

Sorry am running windows 8.1 64bit

Any suggestions?

Firefox screen shot Large picture This is the Firefox screenshot

Chromes screenshot Large picture Chrome screen shot

marked as duplicate by Ƭᴇcʜιᴇ007, Ramhound, bwDraco, ᔕᖺᘎᕊ, Nifle May 3 '15 at 19:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What OS is this? – Dave Apr 29 '15 at 11:44
  • @Dave - The HP Probook 450 G2 comes with Windows 7 – Ramhound Apr 29 '15 at 11:45
  • @Munkey - A few versions ago Chrome change the way it did fonts, if you liked the old way better, disable that feature. There are tons of questions on the front rendering of Chrome. – Ramhound Apr 29 '15 at 11:46
  • Did you update all drivers and graphic drivers - and update from the HP website, not Windows update – Dave Apr 29 '15 at 11:46
  • 2
    @Munkey - Have you searched for the answers on the questions surrounding the changes with Chrome and font rendering? – Ramhound Apr 29 '15 at 13:02
0

So I found the solution to the Chrome issue, on this link

solution to chrome issue on super user

[...]

The main issue here is that Chrome uses Windows GDI to render fonts while most modern web browsers that run on Windows use DirectWrite instead.

The Chrome development team has integrated full support for DirectWrite into Chrome Beta -- and Dev and Canary as well -- but have not enabled it by default.A

[...]

    Type or paste chrome://flags into the browser's addressbar and hit enter.
    Hit F3 and type directwrite. Chrome should jump to the Enable DirectWrite experiment right away.
    Click on the enable link to activate it.
    A relaunch now button appears that you need to click on to restart the browser.

[...]

I was struggling to find the solution for Firefox. I had a play with direct write settings in firefox, using 'about:Config' but this didn't solve it.

I found a sort of solution to the problem. It forces a manual font choice that displays ok in Firefox.

- Go to your Firefox options and choose Content.
- In Content choose advanced settings.
- In Advanced settings, make sure to uncheck the box that says: 

'Allow pages to choose their own fonts, instead of my selections above. After unchecking the box, click ok'

This fixed my font display issues in firefox I found this information while searching on this link

Firefox font fix link

Not the answer you're looking for? Browse other questions tagged or ask your own question.