0

I followed the guide at http://kb.netgear.com/app/answers/detail/a_id/8898 in order to setup a VLAN on my network.

Currently, one port is on VLAN 10, all the rest are on the default. If I plug a machine into that single port, it gets an IP and I can connect to the internet. All is well.

What I'd like to do is plug in a wifi router (The Netgear R6100), which is set in AP mode, to that port and have it give connected machines access to the internet.

What happens when I plug in the wifi router is that machines that connect to it are given IP addresses in the DHCP range that was set on the Netgear FVS318N router. That's good... that's expected. But what I cannot figure out is why they cannot ping the internet. DNS works, but there's no net connection.

I am fairly certain that I am missing something basic. I have screenshots that I can post if that would be helpful.

  • Netgear GS752 Smart Switch
  • Netgear FVS318N Router
  • Netgear R6100 wifi in AP mode

EDIT: [internet] - [FVS318N router] - [GS752 switch]

  • Port 1 on router is connected to port 39 on switch.
  • The wireless AP is connected to port 48 on the switch.

  • The wireless ap gets an IP from 10.0.0.1/10.0.10.1, the laptop connected to the wifi router gets a dynamic I Pand set from the settings on 10.0.0.1

  • What happens when I take the wireless AP out of the equation, and plug the laptop into port 48 on the switch? The laptop gets an Ip address on the vlan as expected and I can browse the internet, etc.

  • If I plug in the wireless AP into port 48, the wireless AP gets an IP address from the vlan as expected and my laptop can connect wirelessly. I can ping the gateway (10.0.10.1) and I can ping the wireless AP (10.0.10.3) but I cannot ping anything outside, such as 8.8.8.8.

enter image description here enter image description here enter image description here enter image description here enter image description here

  • DNS is working on the laptop connected to wifi, but pinging the internet does not work. – NinjaCat May 1 '15 at 1:36
0

I am assuming you are plugging in from your switch to AP on LAN side. What do you have your DNS set to on the VLAN10? Have you tried statically assigning 8.8.8.8 to your laptop DNS when connecting to AP? Have you checked the logs for any dropped or blocked packets?

  • So I have tried plugging in the wifi AP usin gits LAN port as well as the WAN. Makes no difference. And I have tried manually setting the DNS to 8.8.8.8, and that makes no difference either. – NinjaCat May 1 '15 at 13:41
  • logs? So your configuration is Router – feelinloose May 1 '15 at 15:57
  • You should be plugged into the LAN side of your AP or WAN side from docs. I am not that familiar with your AP but I do not think it supports VLANs. Try to statically set your AP to IP 10.0.10.2 SUB 255.255.255.0 GTWY 10.0.10.1 – feelinloose May 1 '15 at 16:18
  • Also make sure DHCP server is turned off on the AP. You do not want it giving out IP's. that will be done by the router. – feelinloose May 1 '15 at 16:26
  • DHCP on the AP is turned off. Client machines get IPs from the FVS318 router. If I plug in a laptop to the port, I get an IP in the VLAN10 range and it can get to the internet. if I plug in the AP, even a WNAP210, I get an IP but no internet access. Wondering if I need to configur ea route on the switch or router... – NinjaCat May 4 '15 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.