15

Using bootcamp to create a mountable installable USB drive with a Windows 10 .iso gives me an error saying:

Boot Camp only supports Windows 7 or later installation on this platform. Please use an ISO file for Windows 7 or later installation.

Why does this happen, is there any way I can fix this, or is there any alternate .iso. I can confirm this is the 64bit .iso and that my MacBook Pro is 64bit.

  • What version of Bootcamp? What version of OS X? Windows 7 support actually was retired so I can sort of tell your not using the current version already. – Ramhound May 1 '15 at 10:11
  • OS X Version 10.9.5 (Mavericks), Boot Camp Assistant Version 5.1.2 – Locke Donohoe May 1 '15 at 10:16
  • I can't tell if there is a newer version then 5.1.2 I suspect there is since your still on 10.9.x instead of 10.10.x has your research indicated this should be possible my research indicates as of Oct 2014 it wasn't possible – Ramhound May 1 '15 at 10:23
  • On the Apple Website and store it only said 5.1, on Wikipedia the latest listed version is 5.1.2 but on my sister's macbook running Yosemite it is version 5.1.3 (not much difference I would think) – Locke Donohoe May 1 '15 at 10:29
  • If Windows 10 is going to work then it will require the most current version. My research seemed to also indicate it required you to be running Yosemite. Bootcamp should actually not even accept Windows 7, or at least warn, about the lack of support since they already made that announcement. – Ramhound May 1 '15 at 10:31

10 Answers 10

16

For me the solution was just to Unmount the windows 10 iso.

If it's not working, I found another solution, you have to edit the info.plist of the Boot Camp Assistant's package content:

  1. Open a Finder window.

  2. Navigate to Applications>Utilities

  3. Control Click or Right Click on Boot Camp Assistant and select "Show Package >Contents"

  4. Open the Contents folder

  5. Drag the file "info.plist" to your desktop (I also recommend saving it in >another place as well in case you want to revert to the original)

  6. Open info.plist on your desktop with a text editor

  7. Find the field labeled as below:
    <key>32BitSupportedModels</key> <array> <string>MacBook7,1</string> <string>MacBookAir5,2</string> <string>MacBookPro10,1</string> <string>MacPro5,1</string> <string>Macmini5,3</string> <string>iMac12,2</string> </array>

  8. Time to find what your Mac is. Click the Apple in the top left hand corner and select About This Mac

    • Click More Info...
    • Click System Report...
    • Under Hardware Overview, look for Model Identifier and copy it
  9. With your Mac's Identifier copied, go back to your open info.plist file create a string at the TOP of the entries. So if your Mac identifier was "iMac13,2" then it would look like this:
    <key>32BitSupportedModels</key> <array> <string>iMac13,2</string> <string>MacBook7,1</string> <string>MacBookAir5,2</string> <string>MacBookPro10,1</string> <string>MacPro5,1</string> <string>Macmini5,3</string> <string>iMac12,2</string> </array>

  10. Save and close info.plist. Drag info.plist back into the Contents folder and select replace. (You may have to authenticate and enter your admin password).

  11. Start Bootcamp and it should allow you to use your Disk/USB with both versions. I wouldn't recommend installing the x86 (32 bit) version of Windows 7, but this will allow you to get to the point of the installation to select x64 (64 bit) if you have an ISO file with both 32 bit and 64 bit combined. Hope this helps.

https://discussions.apple.com/thread/4747024

Caution, you might be resign the package:

  1. Open your terminal, use the following command sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

https://discussions.apple.com/thread/5479879

  • 2
    Answers contained in remote links depend on the remote link remaining active. Could you provide more details here ? Thanks. – suspectus Aug 30 '15 at 13:09
  • It's been a long time, but I added content from the remote link. Hope it's better like this. – Julien Malige Jun 2 '16 at 19:42
3

I had the same issue and this worked for me:

  • (close Boot Camp if it's running)
  • Create backup of info.plist (inside package contents of Boot Camp Assistant)
  • In info.plist scroll down to section Win7OnlyModels
  • Delete the model ID "closest to yours" (in my case, I have a MacBookPro5,3 and the model ID in the list was MacBookPro5,5)
  • Replace old info.plist file
  • Run Boot Camp Assistant

Hope this works!

  • It no longer seems possible to modify the original Boot Camp Assistant.app/. I created a copy and modified that, but it still didn't seem to work. – Jeremy Banks May 29 '16 at 21:41
1

The System Integrity Protection in newer versions of OS X prevents modification of Boot Camp Assistant.app/, as suggested by other answers. I tried duplicating the file and I was able to modify the duplicate, but it didn't fix the issue for me.

I solved this problem by tricking Boot Camp Assistant with a Windows 8 ISO.

  1. Download both Windows 8 and Windows 10 ISOs from Microsoft (you don't need a license to download the installers).
  2. Create a copy of the Windows 8 ISO and name it windows.iso.
  3. Select windows.iso in Boot Camp Assistant. It should accept it.
  4. When it prompts you to confirm that you want to format the disk, wait.
  5. Delete windows.iso.
  6. Open the Trash, right-click on windows.iso and select "Delete Immediately". (Emptying the Trash will fail because it was already opened, but specifying it directly seems to avoid this.)
  7. Rename the Windows 10 ISO to windows.iso.
  8. Return to Boot Camp Assisant and confirm, to continue the process.

After using the Windows 8 ISO to pass the verification process, it can successfully use the Windows 10 ISO we swap in to create and use an installation disk. I'm making this post from a resulting Windows 10 installation on my iMac.

0

This page is 1st or 2nd in google for this error message, so I just thought I'd post what ended up working for me:

  • Date: 4/21/16
  • El Capitan 10.11.4
  • Macbook Pro (Retina, Mid 2012)

Attempted to install Windows 10 directly from the Microsoft website and got the same error message:

Boot Camp only supports Windows 7 or later installation on this platform. Please use an ISO file for Windows 7 or later installation.

What worked for me (or at least seems to be working, I'll update if not) is installing the latest ISO for Windows 8 from the Microsoft website, and updating to 10 from within 8? Wish me luck folks.

0

For me the solution was to make sure and download the 64bit version of the "Windows 10" edition and not the "Windows 10 N" or "KN" or "Single Language" editions.

0

For MacOS Sierra 10.12.6:

First, copy Boot Camp Assistant to your Desktop. Then using a text editor, such as XCode or Sublime Text 3, open the Boot Camp Assistant app which we copied to the Desktop, and find the info.plist file at

/Users/YOUR_NAME/Desktop/Boot Camp Assistant.app/Contents/Info.plist

Find the key "SupporedNonWin10Models", and delete the string containing your mac's model number (which can be found in "about this mac" > system report > hardware > model identifier)." So for me, I deleted

<string>iMac12,1</string>

Save the Info.plist file, and resign the code in terminal using

sudo codesign -fs - /Users/YOUR_NAME/Desktop/Boot\ Camp\ Assistant.app

Now open the Boot Camp Assistant copy on the Desktop and it will give the option to make a Windows 7 or newer bootable usb instead of a windows 7 or 8 USB.

0

I have just found another way. I tried all the methods listed here by the wonderful people who have taken their time to help out. So, in info.plist scroll down to section “SupporedNonWin10Models”.  And remove the line that shows your Mac model. In my case it's MacBookPro8,1.  Save the file and then run boot camp assistant. It should give you the “Create a Windows 7 or later version install disk.” I hope this helps!

0

For me, upgrading the operating system did not work, it still said to use a higher version of OS (even though I was using the latest from Windows site). I selected the old windows 8 version iso, then after clicking next, but before formating the USB drive, i replaced the iso in the folder with the windows 10 image, using the same filename - but then it gave an error when starting the installation - that the disk was not Win7 or higher.

Now I am downloading older version of Win 10 from here to try: http://windowsiso.net/windows-10-iso/windows-10-creators-update-1709-download-build-16299-15/windows-10-fall-creators-update-1709-iso-download/

0

I have used Boot Camp multiple times and had the same problem one time because of corrupted ISO file. Make sure the Windows ISO file is downloaded from Microsoft.com. Here is a snapshot on latest macOS Catalina 10.15:

Windows 10 Loaded in Boot Camp

0

I can't comment so I'll just reply. For those tinkering with Boot Camp Assistant.app:

Do not modify the original system's app! Copy the app to another folder, rename it to Boot Camp Assistant Mod.app or something else, and thinker with that copy. This way you'll retain the original untouched .app, just in case something goes cuco!

Better safe than sorry!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.