I can't make Windows 7 Search work. I type part of the file name, in this case "add" but nothing pops up.

The folder looks like this: enter image description here

After the search there are no results: enter image description here

Sorry for polish language, hope you can figure.

What I already did:

  • Rebuilt the whole index and made sure that the files folder is under indexing
  • Turned off and on Windows Search function
  • Restarted the laptop several times

I have more than 40k files under indexed locations and only 8k indexed elements as the windows states. I'm not sure, maybe those are folder, not files named as elements here.

Nothing helps and I wish I had a mac. Since I'm stuck with Windows for now, please advice.


4 Answers 4


This free Microsoft tool may be of some help.


I know the issues with Windows Search are not uncommon. If this will not help, google it with bit more details, there are tips available, just like this:


  • 1
    LOL. This tool only removed search bar from Windows Explorer. Microsoft is like a dentist. Can't fix the teeth, let's remove it. Ridicolous. May 1, 2015 at 17:16
  • @JacekKwiecień you can re-add it by going into add/remove Windows features and ticking "Windows Search".
    – user256743
    May 2, 2015 at 17:00
  • @JacekKwiecień - Really? Then yes, this is ridiculous. I've never really used windows search much (I'm TotalCommander user since time immemorial)... Sorry.
    – AcePL
    May 2, 2015 at 19:02

At some point I got fed up with the standard Windows Explorer search and installed FileLocator Lite. I can't recommend it highly enough. https://www.mythicsoft.com/filelocatorlite


Windows Explorer search use Windows Search service. Turn on it.

Change indexing option if need add place:

enter image description here

Type at Run dialog (Win+R):

search-ms:query=((ext:.doc)OR(ext:.docx)) Underground
  • What do I do with this? May 1, 2015 at 17:08
  • search Underground word at all .doc and ..docx at all place
    – STTR
    May 1, 2015 at 17:10
  • I did say that I turned off and on Windows Search and also made sure folder is under indexing May 1, 2015 at 17:11
  • You can even search for a disabled search. Simply, it will be much slower and with a lot of CPU time. In your example, you are looking for a part of the file name. You can shorten the search by using the search-ms:query=LIKE(filename:"*add*") In this case, the search will not take place within the file and turn on Windows Search. Or use other means of searching and indexing.
    – STTR
    May 1, 2015 at 17:35

The only way to make sure search settings are reset is to reinstall Windows. You might also have luck with a System Restore. But my first solution is the only definite answer. And if your leg hurts, and you call the doctor and just say "ow my leg hurts", they'll have to ask a bunch of questions and still might not get to the bottom of the issue, so it is not really a specific question, which is a demand on this website, but rather you have a practical problem, which is not particular in any immediately obvious way.

It might not be obvious, but there are a lot of things that could have affected search indexing, and no one can say better than you what (could have) happened. You haven't even mentioned specifics such as where the folder is located, whether search works in other folders (then there's the debugging part where you compare this folder with others such as path length and whether the path contains diacritics). So now you see how yours is not a question?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.