0

I am trying to get a Gigaset C470 IP to work on my Internet connection. I have figured out the correct configuration for the device and my router (a pfSense sitting between the DSL modem and the LAN) to the point that I can make outgoing calls and receive incoming calls.

Outgoing calls work without any issues. On incoming calls, however, audio works only for the first second of the call – after oe secod has elapsed, there is no audio in either direction. The call stays up until one end hangs up.

A packet capture on the external interface of the pfSense reveals that the following happens:

  • I get a SIP INVITE
  • The Gigaset responds with 100 Trying and 180 Ringing
  • I accept the call, the Gigaset responds with 200 OK
  • There is RTP traffic in both directions
  • A second into the call, the Gigaset responds with a new INVITE to the calling party
  • More bi-directional RTP traffic for another 0.1 s
  • After these 0.1 s the SIP provider responds with 100 Trying and later with 200 OK
  • Following the 100 Trying there is no more incoming RTP traffic. There is still outgoing RTP traffic, but neither party can hear the other.

Looking into the codecs used, both parties settle for G.711 following the first INVITE. As far as I can tell from the trace, the RDP traffic indeed uses G.711. The re-INVITE proposes a set of codecs that slightly differs from the original INVITE but both parties apparently agree to continue using G.711.

However, the re-INVITE seems to cause the remote end to stop sending or accepting any further RTP for this call – but why? And what can I do about it?

1

Make sure to get one single codec in the 200 OK answer.

Some servers will send you a second re-invite if they receive 200 OK with multiple codec in the SDP.

To solve this problem, have a look at the current OK in the logs. Extract one of the codec from the list (your preferred one). Then allow only that codec in your Gigaset device.

This should fix the problem.

  • Thanks for your answer! I just tried to reproduce the fault, and now incoming calls work (though now I'm having issues with outgoing). Seems like the provider changed something on their side. – user149408 Mar 5 '16 at 21:09
  • While trying to trace the issue down, my firewall went haywire and I had to reinstall. Took me a while to get things up and running again, but now both incoming and outgoing calls work. No idea if the provider changed something – they must have, because the Gigaset still runs the same firmware versions, and the firewall is unlikely to interfere at this protocol level. In short – everything works now, don't know what caused the issue. – user149408 Apr 9 '16 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.