I have been trying to do port-forwarding on my router (Huawei E5172 4G Router). I've done this before and it worked but i can't get it to work on this router, and i have no idea why!

This is a screenshot of my router cpanel in the security tab and the port-forwarding section specifically :

CPanel - Security - Port Forwarding

And as you see here, all the settings are correct, but still it doesn't work:

FTP Port Settings


While I was searching for some solution i came across something about setting the DMZ to your Local host adress which is in my case

DMZ Setting

But nothing changed.


This was an ISP issue, after contacting my ISP they informed that the service need to be added for 5.3USD, i told them to add the service and its now working. Thank for you help!

  • I have the same problem, got a Huawei 4G router, but port forwarding doesn't work
    – Kametrixom
    Jan 16, 2016 at 13:49
  • Others have the same problem, turn out to be that the router must be 'unlocked', check this guide : dc-unlocker.com/huawei-e5172-detect-and-unlock-guide ! You can brick your router so think twice Free alternative is using YobbGSM unlocker .. get the IMEI paste in unlocker ... check here : yobbgsm.blogspot.bg/2010/03/free-huawei-calculator.html or Google / check download for viruses !!! /
    – Setekh
    Jan 16, 2016 at 23:24
  • It is a bad idea to setup a DMZ, since in effect it exposes your computer to the Internet so it loses the protection of the router as a firewall and becomes reachable by every script kiddo out there. For the problem: Please explain what you mean by "it doesn't work" as different from what worked with the previous router.
    – harrymc
    Jan 17, 2016 at 19:01

3 Answers 3


Using Zain, I suppose you are in the Middle East. When I was in KSA, I also had this same Huawai 4G Router. While the software allows you to set port forwarding/enable DMZ, it won't help you! With 4G the provider is likely using CGNAT (Carrier Grade NAT). Otherwise, every router and also every phone would have to get it's public IP, and there are just not enough IP-addresses left as of 2016.

So, while you can set port-forwarding, you will only forward ports from the internal router of your provider, but not from the public internet address. It is just not possible and you would need to get a landline/FFTH if you want your own public IP address.

EDIT: Just spotted the Zain BH -> Bahrain. So I guess it will not be any different from KSA. No way to get working port forwarding.

  • what if i changed the router, will there be and difference? and what about getting my own publ/ic IP, i didn't get the part where i should get a landline! What did you meant?... Sorry for the slow understanding :) Jan 24, 2016 at 0:01
  • Changing the router doesn't help. The problem is with Zain (and every other 4G internet package). If you want port forwarding, you need a provider/package that gives you a public IP. You will only get this with a landline connection. A quick search showed Batelco with their ADSL or FTTH broadband packages. But those are typically expensive and nowadays even with landline you cannot be sure to get a public IP. Don't be sorry. We're here to help :)
    – TJJ
    Jan 25, 2016 at 2:23
  • here's the thing, my brother have an internet package from Zain it self, he got it a couple of years ago, anyway, i used to be able to port-forward in his router (It's not 4G) and i still can, i'm not sure weather he have a landline phone with the same package or not. so i think it might be possible to do that if they still provide the same package. Jan 26, 2016 at 3:19
  • Yes. Basically any 4G package will not work.
    – TJJ
    Jan 26, 2016 at 3:33
  • 1
    Hello, sorry i didn't notice the comment. Yes i contacted them and they actually did it and its working as it should. Jul 7, 2016 at 8:17

You only need a DMZ if you want a whole computer to be available direct to the Internet. If you are forwarding individual ports, you shouldn't need it.

When you've done this before - was it on the same 4G network? Some networks are already NAT'd which means that your router cannot be reached from the Internet no matter what you do. In the UK, for example, BT do this and in some countries it is common. It reduces the number of IPv4 addresses ISP's have to use up.

Also check the "Firewall Level" I see listed on the menu - what is that set to?

ASIDE: Opening FTP to the Internet is a really bad idea! FTP passes credentials in clear text over the wire and opens you to identity theft (if you reuse passwords) and also opens your systems to potential hacks. I recommend only ever running encrypted connections such as SFTP or FTPS or SCP over the Internet.

You will also find that common ports are constantly scanned by botnets looking for systems to infect, best to avoid them if possible.

  • Ok then, I don't need DMZ, got that. When i did this before it wasn't a 4G network and it was a different router, but from the same ISP. I did called my ISP to check if the issue is from their side or if they are blocking Port-Forwarding, at first they gave me a PDF document with instruction on how to do it on this router, of course i already knew how and it was the same way i did it, then they told me to go to them and bring my router with me to see why port-forwarding is not working. May 4, 2015 at 20:23
  • I will change the ports after i make it work May 4, 2015 at 20:26
  • Ha ha, I love the idea of going to your ISP with your router! I wish more ISP's were that responsive. :) May 5, 2015 at 11:09

Same issue with me, tried port forwarding or DMZ no luck, then after investigation I understood that my ISP which is actually a phone carrier (Three IRL) don't support DMZ and Port Forwarding, I suppose that make sense as I'm using a Phone SIM card... very annoying for me though.

I suppose a solution would be to permanently connect to a VPN server.

UPDATE : after more research, I figured out that with some carrier you can just change the "APN" settings, and then have NAT / Port forwarding / DMZ

  • 1
    Read the comments on TJJ answer to know how it worked for me Oct 14, 2017 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .