In previous versions I could do this with gsettings set org.gnome.shell.overrides button-layout close,minimize,maximize: but now I get error no such key "button-layout" In GUI there is no button-layout in dconf-editor

So how can I add maximize and minimize buttons in Debian 8?

up vote 13 down vote accepted

I was looking for the same and shortly after reading this question I found the solution for my setup (Debian 8, Gnome-Flashback): The relevant key is in org.gnome.desktop.wm.preferences, "button-layout". Edited with dconf-editor from "appmenu:close" to "appmenu:minimize,maximize,close" and the buttons are back :-)

Regards, Joachim

  • 1
    Another +1; there's a lot of out-of-date info on the web out there, this one does actually work on my Jessie with gnome flashback. – timday May 17 '15 at 10:35
  • 4
    So does this mean: gsettings set org.gnome.desktop.wm.preferences button-layout appmenu:minimize,maximize,close? Could you put that into a command someone can use? – Zelphir Mar 27 '16 at 0:18
  • 1
    @Zelphir: I've tested your command on Debian 9 "Stretch" with Gnome 3.22.2 and it worked perfectly. – Fabio Turati Jan 16 at 10:26

Utilize

For window buttons, I use Preference > Windows and have just the "Close" button on left side of the window. This fails for ALL GNOME applications, like Nautilus, Calculator, Gedit . .

or Gnome-shell and use the tweak-tool.

screenshot

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.