1

For some reason, our government ISP filters our ADSL connections greatly when using routers, while if we connect directly our computers to the ADSL modem we get the speed we pay for.

So, i am using windows 7's internet connection sharing and virtual wifi adapter on an old laptop to create a virtual wireless ssid , but i want to try to give the router internet access by connecting the laptop's ethernet port to the router's wan port, but i don't get internet to the router.

my router has "wireless router mode" , " repeater mode" and "access point mode"

If i got you consided, here's a summary ADSL modem:---USB CABLE---LAPTOP LAPTOP:----virtual wifi driver----virtual ssid (phones have internet)

I want to delete that virtual ssid and instead use the router. Remember i can't connect the router directly to the adsl modem because i would get filtered.

I can change the shared connection from the wifi adapter to the ethernet adapter, but i don't get internet in the router. Do i need to change its mode? Or configure an ip address manually in the router? ICS ip addresses are 102.168.137.x

My router is: asus rt-n66u. Thanks

2

Here's the solution, i was really near it, but ICS always puts me down.

  • Share your laptop's internet connection to the ethernet port. That changes its ip to 192.168.137.1
  • Plug the laptop's ethernet port to your router's WAN.
  • Set your router's WAN IP manually to 192.168.137.xxx where xxx is anything between 2 and 254, subnet 255.255.255.0 and and gateway 192.168.137.1. The problem was that ICS wasn't providing my router with this automatic configuration so i had to set it manually.
1
  • Why are you connecting to the router's WAN port at all? The router is not connected to the WAN but only to a LAN. You made this harder than you needed to. – David Schwartz Feb 18 '20 at 3:45
1

A few comments:

  • I would not use WiFi to connect your router to the computer. You want 2 Wired Ethernet ports for your laptop: get an extra USB Network card, and use that to connect to your Router's Wan port. Then configure the router as normal.

  • it may be easier to find other workarounds to this problem. Are you sure it's caused by an intentional throttling? Could there be other factors at play, maybe a router problem? You can also change your Asus router's WAN MAC address to the MAC address of a another device so that it will "look like" a computer to the other end.
1
  • i am buying a usb based ethernet card to add to the laptop to avoid using its virtual wifi, so i can use the router's own wifi. But while my dad is visiting the states and wlll buy it, i am trying to get it to work while he comes back. I have tried 3 routers and different network cables. I don't know if it's intentional or just some weird incompetence coming from my isp, all i know is that if i connect directly to the modem i get 4 mbps, and when connecting the same cable to the router's wan, i only get 0.3 mbps. I even tried spoofing the asus mac to an isp's router and i get a new ip but slow – fjleon May 3 '15 at 15:23
0

Consider this scenario:

You plug the computer A offering the Internet connection to a LAN port in your router.

You connect an other computer B to the router via WiFi.

Normally you can ping computer A from computer B. (Except if "Wireless clients isolation" is enabled which you should disable).

Now go to the LAN settings of your router and configure the DHCP server in the way it provides its clients with computer A IP as their gateway and any public DNS server IPs such as those of Google 8.8.8.8 / 8.8.4.4 as their DNS servers. Although, if your router doesn't offer the possibility to set these settings then you'll have to set them manually in each client computer.

Please report back.

1
  • i just fixed it. turns out my login was sound - connecting the laptop's ethernet port to the wan of the router. The issue is that windows ICS doesn't seem to set up a dhcp server (or doesn't work fine) so the router didn't know what WAN ip to use. I had to configure my router's wan ip manually to 192.168.137.254 and gateway 192.168.137.1 and now i am connected via wifi on another laptop with my full 4 mbps speed – fjleon May 3 '15 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.