8

I've been trying to get this working all day, and I have a strong feeling that my issue is specific to Yosemite. I'm running OS X 10.10.3 on a retina Macbook Pro.

I took instructions from http://www.robpeck.com/2010/10/google-chrome-mac-os-x-and-self-signed-ssl-certificates/

But while that does indeed fix the errors thrown by Safari, it does not fix the issue in chrome. I can "proceed anyways" but the red crossed out lock is not going away. I want to implement a feature in a web app that requires SSL support in Chrome specifically, but I can't test it locally due to this issue.

Does anyone know why this is happening? Or if it's not even possible to do this?

  • I have the same issue. I think mine stems from the fact that the machine I'm trying to access [a gateway/router] doesn't have a fully-qualified domain name & Chrome objects to that. Safari is fine with it after the method you linked, just not Chrome. – Tetsujin May 3 '15 at 6:44
  • Check here for answer: stackoverflow.com/questions/7580508/… – Romeo Ninov May 3 '15 at 7:55
3

Try enabling the "Allow invalid certificates for resources loaded from localhost" flag in chrome, enter "chrome://flags" in the URL box of chrome, search for "invalid" (part of above flag name), click enable, and restart Chrome.

| improve this answer | |
  • Nice tip. Never knew this flag existed. – TrophyGeek Mar 9 '17 at 22:03
  • 1
    Mine is not on localhost – mjaggard May 23 '18 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.