3

I installed Windows 98 in QEMU. I want to run networking in user mode. I start it with qemu-system-i386 win98.img -m 256 -soundhw sb16 so it should be using default network hardware and probably working. In Network adapters section of Device manager I see only "Telephone adapter" (not sure about translation), no other NIC. I think that's the problem, anyway here are other details: I tried setting the IP address manually to 10.0.2.16, nothing changed in output of ipconfig /all. ping 10.0.2.2 reports destination host unreachable. ipconfig /all reports only one interface, Ethernet adapter, its description is "PPP Adapter".

3
  • 3
    Which hardware did you select in Qemu? Did that include a NIC? If it did, which model is it emulating? Are there drivers for that model in win98 (if not it will be an unknown device in 98's device manager).
    – Hennes
    Commented May 3, 2015 at 13:37
  • I edited it to add the command I used to start it. I also tried -net nic,model=e1000, no change. There's no unknown device in device manager. That's all I did to select hardware.
    – user443482
    Commented May 3, 2015 at 13:50
  • necro bumping, but did you manage to solve this ? Commented Jun 7, 2020 at 22:23

3 Answers 3

2

Windows 98 likely can't detect the Plug&Play BIOS. To work around this, configure your windows for direct hardware access. To do so, go to Device Manager, locate the Plug&Play Bios with the yellow exclamation mark, Properties, Update Driver, Select Location, List all Devices, then select "PCI Bus".

This will find a bunch of devices, such as the graphics card, better IDE drivers and so on.

0

Just in case try installing the PCI bus device manually, even if the Plug and Play wizard doesn't work

0

My experience is that msw98 does not recognise Plug&Play BIOS, hence it cannot see the PCI NIC at all. My hack is to define ISA NIC:

-net nic,model=ne2k_isa,irq=3,iobase=768,macaddr=aa:bb:cc:dd:ee:ff:00 
-net user

and manualy install driver: Standard National Semiconductor NE2000Plus

The IRQ-3 and IO=768(=0x300-0x31F) is the ms-windows default settings, if you need st. else, be carefull with configuration.

BTW: I can browse the Internet, but cannot connect to samba server. The reason may be the new version of server's samba which ignore the too old version msw98 samba.

I use something like this:

qemu-system-i386 -name msw98 -M pc -m 256 -cpu pentium3,kvm=off \
    -smp cpus=1 -rtc-base localtime -display sdl -vga cirrus \
    -hda diskC.qcow2 -cdrom CD98SE.iso \
    -net nic,model=ne2k_isa,irq=3,iobase=768,macaddr=aa:bb:cc:dd:ee:ff:00 \
    -net user \
    -serial none -parallel none -no-kvm -no-acpi \
;

Please, drop a note, about your luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .