1

I made a common mistake of not reading the whole manual and installing Nvidia drivers. Now Xorg won't even start. I read that reconfiguring Xorg fixes that but it's not working for me.

My system:

  • Debian 8.0.0 Jessie
  • Laptop with Intel HD Graphics and Nvidia GeForce 540m with Nvidia Optimus.

When I tried dpkg-reconfigure x11-common, I got this error message:

update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults.

1
  • have you tried sudo X -configure May 3, 2015 at 21:27

2 Answers 2

1

I would recommend you remove the nvidia drivers and retry this. Installing Nvidia drivers with optimius support is tricky. You will need bumblebee, you could still use only the nvidia card (or only the intel one) without bumbleebee. Try

update-alternatives --config glx

Which should let you select between the two cards. When you select the nvidia card you can use nvidia-xconfig to automatically set up your xorg.conf. nvidia-xconfig can be downloaded from the repository

Removing Nvidia Drivers:

If you installed the nvidia drivers from the official repositories, what you need to do is:

apt-get autoremove nvidia*

If you installed the drivers by manually downloading them from the nVidia website, then what you will want to do is run

nvidia-uninstaller

Your next step will be to revert any changes made to your xorg.conf configuration file. By default it is empty on Jessie (unless im mistaken).

cd /etc/X11/
rm xorg.conf
rm /etc/X11/xorg.conf.d/20-nvidia.conf

Now; when installing the nVidia drivers the built in nouveau drivers are disabled by the addition of a file which blacklists. To re-enable nouveau you will have to remove a file that was generated by the nVidia installation. One of the files in /etc/modprobe will have a line that reads blacklist nouveau. Delete that line, save the file and then run the command

update-initramfs -u

Finall just reinstall the nouveau drivers to make sure nvidia has not overwritten anything

aptitude install xserver-xorg-video-nouveau and xserver-xorg-video-intel

This should revert what the nVidia installation might have done.

0

The package you need are libdrm-intel1 for Intel drivers libdrm-nouveau2 for Nvidia drivers

And check on xserver-xorg-video-nouveau and xserver-xorg-video-intel

Remove all package with nvidia name

And check your blacklist

If you want to have support with optimus, take a look on primus package

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.