0

The problem:

I cannot log into either of two migrated profiles on an OSX 10.6 system

What I did:

I'm rebuilding an OSX 10.6 system for someone due to a failing disk. The old disk was unbootable but could be read when mounted. Repair failed consistently, but certain parts of the disk seem to have been untouched - such as the bootcamp partition and /Users.

After installing OSX on a new disk I noticed OSX has a handy profile migration tool. There were just 2 profiles but they contain around 100Gb of stuff. The import seems to have worked, with no anomalies reported.

What goes wrong:

When I try to log into the imported profiles I get the shaking password textfield. If I try to log in via ssh I get access denied. I haven't yet investigated if ssh access is somehow restricted. These accounts have been made administrator accounts. This is a standalone Mac, no domain or outside authentication. OSX says there are no outstanding updates.

I've spent quite some time on the apple forums trying to work out what might be wrong. Its obviously an authentication issue, but I cannot find anything being logged.

What I've tried:

  • I've tried resetting the password from preferences.
  • I've tried booting to single user mode and resetting the passwords with passwd.
  • The logs in /var/logs aren't revealing anything obviously going wrong.
  • The owners of the directories and files in /Users correspond to the user accounts which were created during the migration process.
  • I can log in via ssh using my account (not migrated)
  • I cannot log in via ssh using either imported acount - it reports Access Denied.

Can anyone suggest anything I can do to track down the cause of this problem - enabling authentication debugging or something obvious I'm missing?

I'm not an OSX expert but have spent a lot of time working with other versions of unix and with Windows.

Update /var/log/secure.log contains the text "in pam_sm_authenticate(): Failed to determine kerberos principal name" - however this is a standalone system - no connection to active directory, nor any other external system.

0

I decided to try just creating another account, moving the contents of the /Users/ directory and then chown'ing it. Worked first time, so it looks like theres a bug in the account creation part of the migration tool.

Previous to this I had tried emptying the migrated users profile directory completely - which made no difference what so ever, neither interactive login, nor ssh would let me log in.

The update I posted above would seem to indicate that osx was not finding the account in the local user db and so was falling back to trying ldap methods. However I was able to consult the list of user accounts from the shell and both accounts were listed - so even weirder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.