0

My primary router is HG 8247 Huawei ONT Device with primary gateway 192.168.100.1. I want to extend its range using a TPLink WR740N i have lying around. I have done the following without success:

  • First method was a wireless link between the two routers. Set Tp-link to WDS bridging mode and set its default gateway to within the Huawei range i.e. 192.168.100.2. Disable DHCP on Tplink. In this way only one device my laptop is able to connect to the TPlink at one time and access internet. Smartphone doesnt connect to Tplink as it stops at getting ip address.

  • The second method was to connect two routers using ethernet cable. I tried both the WAN LAN ports of the TPlink and with and without DHCP disabled (and with/without changing ip address) but I couldnt simply access internet when i connected to TPlink wifi.

Any ideas as to what to do now? Is it a limitation of Huawei?

The WR740N can work this way as many tutorials show but in my case the configuration isnt working.

  • Why did you set Tp-Link's primary gateway to 192.168.100.2? Shouldn't it be 192.168.100.1? – redbeam_ May 4 '15 at 17:58
  • Why would I make it conflict with the Huawei address – Delta May 4 '15 at 17:59
  • I think you are confusing what a gateway is. A gateway is a device with highest position within the network. That means, all devices connected to it send their packets to it. The devices can be connected by cable, or by Wi-Fi. You should read some info on this on Wikipedia: Gateway WDS Bridge – redbeam_ May 4 '15 at 18:10
  • What would the difference in ip addresses achieve basically – Delta May 4 '15 at 18:12
  • Now I know what do you mean. Set up the Huawei like a normal Wi-Fi router and then set up the Tp-Link wi-fi router in WDS mode disable DHCP, NAT and other stuff. That should be it. You should check the IP addresses of the smartphone and the laptop (if they are not the same, if they are not set as static). Oh, is DHCP server on the Huawei turned on? – redbeam_ May 4 '15 at 18:17
0

Connect both routers to your home switch via cat5. Setup both routers to not issue DHCP (or use one only, if you have no in-house server to do so). Configure both as access points using the same SSID, but - and this is the key - on different and non-overlapping channels (ie: ch 1 and 6, 6 and 11, etc). Now, your devices can hope from one to the other as required.

A good link to read more on this can be found here. The channel spacing diagram shows it all.

Secondary router must be set to use primary router as default gateway. I.e. Primary router IP is 192.168.100.1 Secondary Router Ip is 192.168.100.2 with it's default gateway set to 192.168.100.1.

This is necessary to route internal traffic out to the internet pipe(cable,dsl Modem) from the secondary router.

  • Unfortunately that is for Tomato routers and the settings dont match with my router therefore I cant apply those settings – Delta May 5 '15 at 6:22
0

Flashed router with OpenWRT to make it a repeater.

  • 2
    Thanks for closing the loop on your question. Could you expand your answer a little to elaborate for other users who may have a similar question? – fixer1234 May 5 '15 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.