I'm using an X61s laptop (under Windows) that only has a trackpoint, not a touchpad.

The trackpoint has a scroll function that is activated by holding the middle button and then using the trackpoint to scroll. This is very useful and I don't want to miss it.

However, I would also like to use the middle button to open links in new tabs for instance.

Unfortunately, I have not found a setting that provides both functionalities at the same time. Does anyone know if and how it can be done?

Here are some links to people having the same problem, but no solution, unfortunately:

  • 1
    I just got a Thinkpad and I can't believe this doesn't work by default. Any luck finding a solution other than AHK? – endolith Dec 30 '10 at 3:07
  • I would like to see other solution as well. The AHK dont works for me. – Gergely Fehérvári Mar 7 '14 at 1:37
  • @GergelyFehérvári: See whether my answer at superuser.com/q/1029053/276424 works for you! – user21820 Jan 20 '16 at 17:59

Here is a work around just posted using Autohotkey to simulate a scroll wheel while holding down middle click after a certain amount of time:


| improve this answer | |
  • Great! It basically works. And having some kind of source code is a plus, since I may be able to change to fit my needs better. Thanks a lot! – Mika Fischer Feb 27 '10 at 12:08
  • for me the AHK not works. any idea why? I have t430s win8.1pro. – Gergely Fehérvári Mar 7 '14 at 1:36
  • Dear gergely, please ask this in a new question. – BramMooij Nov 19 '15 at 22:09
  • Tested to work on Windows 10, Verison 1903, on a T480 machine. The script mimicked the "default" scrolling experience as of 1. maintaining the cursor location after entering the scrolling mode, and 2. accelerating when pushing the trackpoint with more forcefully. Gllad to find this quick and perfect fix. – llinfeng Jan 14 at 14:07

I'm a thinkpad only guy... and this issue bothers me a lot too. Running Windows 8 currently and finally found this little app that does the trick very nicely. Works with previous versions of windows too! https://github.com/summivox/misc_bin/raw/master/tpmiddle-0.5.exe

Just place it in your startup. Basically... if you press the middle button and don't scroll it will execute the alternate action. So, in browsers usually it will open a page in a new tab. More details in the link, but this solved my issue.

| improve this answer | |
  • I have lenovo thinkpad edge e330 and tpmiddle works perfectly. I've tested it with win7 and win10. For someone who in doubt: if you can't install tpmiddle because of lack of some dll file, you should install Microsoft Visual C++ 2010 SP1 Runtime Libraries (x86), even if you have a 64-bit operating system you need an x86 version. – Cheslab Apr 25 '16 at 9:40

I'm unsure if this affects your Thinkpad, but it worked on mine:

Open up the mouse properties and open the Ultranav tab. Click Settings... and change the Scrolling Type to Smooth.

On my system, a middle click works as expected unless held down. Then it acts as a scroll wheel.

| improve this answer | |
  • Although your solution almost certainly doesn't resolve the asker's issue, it was what I needed to choose to make UltraNav stop interfering with my autohotkey script! So +1 for ending my hours of fruitless debugging! – user21820 Dec 16 '15 at 9:13

Simply go to the mouse properties and under the TrackPoint Tab, find "Choose Scrolling and Magnifying Glass Function". Here select "Neither". This would allow you to open new tabs with the middle click and if you use the trackpoint to scroll, it would scroll too.

| improve this answer | |

I'm using a Thinkpad Keyboard with Trackpoint on a notebook of another manufacturer and also had the very same problem. I fixed it by looking into the keyboard settings: Devices > Lenovo Keyboard >(Rightclick) Keyboard Settings > External Keyboard. There is an option called "ThinkPad preferred Scrolling", deactivating it brings the expected behavior.

screenshot showing the setting

I don't know why the text on the shown image is in German while everything else of the settings windows is in English, as expected. Sorry for that.

| improve this answer | |

Well, I installed the Synaptics drivers from


then, I chose the center button to be the middle click, found the situation worse than before, uninstalled.

Surprisingly, it now works as it is supposed to be ;)

Maybe you can also just remove the driver for it to work as you want.

| improve this answer | |

well i connected a mouse to my t61 and suddenly the middle button became the middle mouse button (the one you are talking about). Maybe you can try that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.