0

So, i got a SSD a few weeks ago and started using it as my secondary storage device (specially really large files that i have to use often) and i noticed it "freezes" and just disappears from the system sometimes.

This computer is never powered off and there were no power outages recently, also the SSD still works after rebooting the machine and there is no trace of file corruption or anything like that. All drivers are up to date and it looks like the SSD is running smoothly without any reported problems.

When this problem happens the computer is left with no trace of the SSD anywhere and there is no way of getting it to work again without rebooting.

Are there any clues what could it be, or at least any suggestion on where i should look for more information about the issue?

4
  • Can you provide some system background... What mainboard & PSU are you using this with? What other SATA devices are connected already? Was there any unusual hardware behaviour before you added the SSD? – Reece May 5 '15 at 23:20
  • My mainboard is an Intel DX58SO and the only other SATA device is my primary HDD (MAXTOR STM35003) and so far, there was never any issue like this one at least. I had a problem with BSODs some time ago but i solved just before i got this SSD – Carlos Cortez May 5 '15 at 23:35
  • Have you tried a new SATA cable? – Karan May 6 '15 at 2:25
  • Yes, tried 3 different cables (the current one is brand new) – Carlos Cortez May 6 '15 at 19:26
0

The first thing you want to do is determine if it's an issue isolated to the PC you are working with. Do the same symptoms exist if you attach the SSD to a different PC? If so, then I'm afraid you have a faulty SSD. A firmware upgrade might help, but given that it's new, I'd send it back for replacement. If the problem only occurs on the PC you use, then the issue could be mainboard related.

Have you set the SATA mode as AHCI (or RAID) to get the optimal performance for an SSD? Have you disabled S.M.A.R.T in the BIOS to see if this helps (this will stop BIOS level error reporting on a HDD though)?

One other thing apart from SSD or mainboard that could be the issue - your Power Supply Unit. Swap out the PSU if you have a spare and see if that helps.

2
  • Sadly i dont have another PC to test this device at the momment, i checked for firmware updates and there are none available so far. The SATA mode is RAID as far as i remember (will double-check as soon as possible, this machine cannot be restarted often). Testing the power supply and so far its still ok – Carlos Cortez May 5 '15 at 23:45
  • Changing the power supply seems to have solved the problem, or maybe the way i reconnected the device did the trick but anyway im accepting this as the answer since the problem ceased – Carlos Cortez May 6 '15 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.