0

What happened?

Something's strange with my computer. Just today, I had to do a battery swap.
Like always, the system is always turned off when the battery is swapped.
Before the battery swap, both operating systems worked fine; both can boot normally.

However, when I turned the machine back on, both of my operating systems (Windows 7 and 8) failed to boot. It would bring me to a Blue Screen of Death, but this BSoD would not show any information, but instead flash, disappear and trigger a reboot back to the main boot menu.

Note: THIS HAS NOTHING TO DO WITH A FAULTY BATTERY (or hard drive)!


What I tried:

I went through my computer information/configuration, and there seemed to be nothing wrong with my BIOS.
I then booted (just to make sure) Windows 7 and 8 normally. Neither worked. All I received was a lightning quick BSoD that I could not capture any infromation from.
I then went on to attempt to boot into safe mode. Strangely enough - Windows 7 failed to boot at classpnp.sys while Windows 8 booted safe mode fine.

After restarting again, Windows 8 booted normally for safe and normal mode, while Windows 7 could not boot at all.
However, whilst in Windows 8, I have noticed that the time has not moved at all; it was still at the time of my last successful shut down.

I then tried restoring back to a previous system state (for Windows 7) using recovery mode, which works correctly.
Sadly, there wasn't a recovery state I could use. So I tried the "System Repair" Utility.
After 5 minutes, it stated to restart the machine and "everything should run as per normal as repairs are complete", but it still gave a BSoD.

After browsing some other sites, many people deduced it as a faulty disk.
But recovery mode for both Windows 7 and 8 worked fine. Even the boot menus (for both operating systems) successfully loaded, which means it isn't a faulty disk.


My questions:

  • If it had nothing to do with corrupted system files, what could be causing Windows 7 to be unable to boot?
  • And because I was able to fix Windows 8 without re-installing (any recovery/install media/drives), is there any way to do the same with Windows 7?

Summarize of what works (as of the asking of the question):

  • Windows 7 cannot boot into safe or normal mode.
  • I do not have any Windows 7 recovery media.
  • Windows 7 and 8's recovery mode works fine.
  • My Windows 8 recovery media is on another partition (but for some reason inaccessible through the boot menu)
  • Windows 8 now works perfectly fine.

Updates:

  • Caught a glimpse of the BSoD error; STOP 7B.
  • Have you swapped back the batteries just to see what happens with that battery in the windows 8 machine? For all you know something happened and that battery is now dead. – LPChip May 6 '15 at 9:38
  • @LPChip Nothing happened. – aytimothy May 6 '15 at 9:38
  • So if you swap the batteries again, now the windows 8 machine doesn't boot, and the windows 7 machine works fine? or windows 7 still won't boot, and 8 is fine? – LPChip May 6 '15 at 9:39
  • @LPChip Give me a minute to test. – aytimothy May 6 '15 at 9:39
  • 1
    Either clock? If your caught in a temporal flux . . . I mean there have been times when on certian computers the on board RTC locks up for some reason, in this case it could be a power glitch. Because you mentioned it , it could be important to other aspects of the OS, usually would not effect the boot though. – Psycogeek May 6 '15 at 10:27
0

Swapping the battery should not affect system. UNLESS something went wrong. Did you used genuine dell battery or a non-genuine replacement? And basically those are designed to be hot-swappable in any case. Not recommended, but not exactly forbidden either.

What I recommend to do:

STEP 0: Run Dell Diagnostics. And take it from there.

  1. Make sure date/time is set to current. Windows may not boot if there is mismatch between logs and time RTC shows. If it needs adjusting, CMOS battery needs replacing, but that's no big deal - as long as there is at least main battery or external power, you're good.
  2. If #1 fails, remove main battery, disconnect external power and then press and hold (or press than release and repeat) for at least 30 seconds the power button to drain power from the system. Then power it back up. You wouldn't believe what weird stuff that solution sorts out.
  3. if #2 fails, Set BIOS to default, save and reboot.
  4. If #3 fails remove CMOS battery and repeat #2. Then replace battery and power system back up.
  5. If all fails, there is, in all probabilities a MB fault. Unless you didn't put back the old battery back in, then repeat all from #1. New battery may be developing a short somewhere...

EDIT: completely forgot about Dell diagnostics. Added it to list above.

| improve this answer | |
  • Just to note, it's a genuine DELL battery taken from... Another laptop of the same model. – aytimothy May 6 '15 at 11:54
  • Then all good here. But just in case, check both batteries in that another laptop. DELL has built-in diagnostics, you should run it. – AcePL May 6 '15 at 11:56
  • Say... Is there any way to find the correct date/time that needs to be set? – aytimothy May 6 '15 at 12:20
  • You just need to set current date/time in BIOS. IIRC it's in General Section. – AcePL May 6 '15 at 12:35
  • I don't get it; it's already correct in the BIOS settings menu... – aytimothy May 6 '15 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.