41

I am using a variety of tools to regularly prepare data for the web. One stage requires me to open a CSV in Excel, make changes and save the file.

Is there a way to force Excel to accept UTF-8 encoding, and to save its files with that encoding?

3
  • 2
    To clarify, I would like to change a setting so that Excel assumes an input file is UTF-8 by default. As mentioned below, LibreOffice/OpenOffice does this.
    – Dizzley
    Oct 30, 2015 at 12:02
  • If you don't actually have Unicode characters to deal with, I'd consider using a middleware to convert all CSVs to ASCII and then open in Excel.
    – Vassile
    Feb 28, 2016 at 7:54
  • 1
    Related question here but not exactly the same.
    – hhh
    Jan 27, 2017 at 8:09

8 Answers 8

21

I answered a similar question at Default character encoding for Excel Text Wizard?.

I found my answer at Changing default text import origin type in Excel.

  1. Close Excel, if it is open.
  2. Open the Registry Editor.
  3. Navigate to HKEY_CURRENT_USER → Software → Microsoft → Office → ▒▒ → Excel → Options, where ▒▒ is your version of Office, mostly likely the largest number you see there.
  4. Right-click an empty space on the right side and select New → DWORD.
  5. Name the item DefaultCPG, and press Enter to save.
  6. Right-click on DefaultCPG and select Modify.
  7. Set the Base to Decimal.
  8. For Value data, enter 65001 to set your default to UTF-8. For some other encoding, use the code page identifier, which you can find in the Text Import Wizard in Excel or in this list.
  9. Click OK.

Like Vasille says in the comment to this question, if your file is not actually in UTF-8 format, you may technically want to convert the characters within the file to the encoding you want before opening in Excel. For my purposes, though, UTF-8 does a good enough job of displaying non-corrupted characters.

Not working? Make sure you set Base to Decimal (Step 7).

Screenshot of Edit DWORD 32-bit value showing setting base to decimal

6
  • 8
    Are there any reasons not to do this? Why is this not the default behavior of Excel? --- My team often deals with datasets containing foreign characters, and I'm wondering if there is any reason to not perform this action on each of our machines. Aug 23, 2017 at 20:43
  • 5
    This unfortunately did not work on my machine. Files still open with default encoding (Win 7, Office 2016). Aug 23, 2017 at 20:46
  • 9
    Doesn't work on mine also, Win 10 Office 2016 Jun 21, 2018 at 3:46
  • 4
    No dice. Excel behaves as stupidly as ever. One would expect an obvious feature like this to be accessible via a user preference in software as mature as Excel. Sep 18, 2018 at 9:22
  • 1
    @Robert H. Is there a way to achieve this on a Mac?
    – alex
    Apr 29, 2021 at 12:36
7

It seems that Byte Order Mark is required by Microsoft Office software.

  1. Using Notepad++, convert the CSV using menu: Encoding -> Convert to UTF8-BOM.

  2. Using the sed Unix utility, available in cmder or Git for Windows. See Adding BOM to UTF-8 files.

    sed -i '1s/^/\xef\xbb\xbf/' file.csv
    

  • Tested with Excel 2016
  • This is what avwtp meant in their answer.
3
  • Setting the BOM in Notepad++ works perfectly fine. Is there a command-line solution for Windows, like at CMD-Prompt or Powershell?
    – snahl
    Jul 12, 2021 at 20:14
  • An answer for Python: f = open(out_filename, "w") #set the BOM to UTF-8. Required for importing csv to Excel f.write('\ufeff') # Close the file f.close()
    – snahl
    Jul 13, 2021 at 14:05
  • Setting the BOM was the fastest and easiest. Thanks
    – Orsu
    Nov 17, 2021 at 14:06
6

One easy way to change excel ANSI encoding to UTF-8 is the open the .csv file in notepad then select File > Save As. Now at the bottom you will see encoding is set to ANSI change it to UTF-8 and save the file as a new file and then you're done.

1
  • I will experiment with this. One problem I have is opening files consistently in the correct encoding so I do not get data in two encodings in a single results file. Then it becomes hard to fix. I really wish Excel allowed me a better way to choose input file encoding.
    – Dizzley
    May 6, 2015 at 14:59
2

You need to use the File > Import option and start with blank document and specify UTF-8

enter image description here

but this is far from optimal to make this a default setting for all files, anyway it is unnecessary to rotate the files around Google Drive or LibreOffice. The defaults are just badly chosen and the disability to change that is irritating.

Related

  1. How to set character encoding when opening Excel but does not find the option to change the defaults such that all files are automatically opened with UTF-8 instead of Macintosh format in OSX

  2. How to change default file option to UTF-8 away from Macintosh file option in Apple.SE.

1

I solved similar problem before. Unsuccessfully, but you can use LibreOffice, which is UTF-8 in default.

1
  • LibreOffice is very handy for this. However, sometimes I have VBA macros to run. Thanks Lluser
    – Dizzley
    May 6, 2015 at 14:56
0

There's an Excel addin available here to work with Unicode CSV files that should help you.

Here's the developer Jaimon Mathew's note:

Excel treats .csv files as text files and will replace all Unicode characters with “?” when saved normally. If you want to preserve the Unicode characters, you would need to save the file as “Unicode text (*.txt)”, which is a Tab delimited file. Since I couldn’t find any existing solution to preserve Unicode characters in CSV format, I thought I’ll give it a go in creating an Excel Addin to do just that.

1

0

It's not the best solution, but it's an option: upload your Excel file to Google drive, open it with Google Tabs and download as a csv file. It worked for me.

2
  • 5
    This does not answer the question how to change the encoding of Excel document.
    – Ramhound
    Oct 2, 2015 at 12:01
  • Of course, when you open the CSV in Excel you lose the cell formatting so some numeric ID strings get converted to integers.
    – Dizzley
    Oct 30, 2015 at 12:00
0

Assuming you have a unix shell available (Cygwin), I append to the front of the csv file a little 3 char unicode ID (UTF-8) and then it reads fine into Excel and more importantly it is properly processed as input using VB Excel automation.

UTF-8.txt

EFBBBF << hex edit into a 3 char file.

cat UTF-8.txt file-to-use.csv > new_file.csv

4
  • 1
    (1) Can you describe how/why this works? (2) Can you describe exactly how to create this UTF-8.txt file? Apr 30, 2019 at 0:41
  • I suggest using a hex editor and typing in the 3 character sequence. Why it works, no idea. I figured out this solution by taking an existing UTF-8 csv file, renaming it to txt, importing it into Excel (like suggested in other threads), saving it as CSV with the Unicode plugin (other thread) and then doing a binary diff of the two files. The only difference was the 3 character starting sequence.
    – avwtp
    Apr 30, 2019 at 19:08
  • See this thread why it works [link] (stackoverflow.com/questions/6002256/…)
    – avwtp
    Apr 30, 2019 at 19:22
  • In bash (OSX) printf '\xEF\xBB\xBF' > new_file.csv then cat the rest in - HT @Yaron U.
    – Mr R
    Mar 13, 2021 at 8:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.