1

I've got a new MacBook Pro (with latest Yosemite) I'm setting up for web development. I am running PHPStorm as my IDE. PHPStorm cannot use its built-in composer functionality, saying it cannot connect to the packagist repo. It seems this is because the mac doesn't have PHP OpenSSL activated:

php -i | grep "SSL Version"
SSL Version => SecureTransport

Is there a way to install OpenSSL without building a whole new PHP with brew or port? I'm using VMs for most of my development now and I'm really trying to avoid customizing the new clean machine, instead messing with all my server stuff in the VM.

Thanks for any help.

0

According to phpstorm support this is a bug in their product. They pointed me to an unreleased beta and the functionality worked as designed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.