I am trying to install an .exe application (Win32 Cabinet Self-Extractor) silently from command line using this PowerShell command:

Start-Process -FilePath "C:\Temp\MMASetup-i386.exe" -ArgumentList "/s" -wait

But everytime I get a pops up window with this error:

command line option syntax error. Type command /? for help.

What am I doing wrong? I am on Windows Server 2012R2 and using PowerShell-4.

  • Do you have a global policy which prevents running the executable from the temp directory? The other thing I would try is using single-quotes instead of double-quotes, since you don't have any variable expansion. May 8, 2015 at 14:31
  • 1
    So when you run mmasetup-i386.exe /s from a command line it works? From what you've written it appears that the mmasetup-i386 is reporting an invalid option. What is the ouput of mmasetup-i386 /? May 8, 2015 at 14:49
  • @DavidPaige: No don't have any that kind of policy, and using single-quotes is also giving same error.
    – serenesat
    May 8, 2015 at 14:49
  • @TonyHinkle: I get this Start-Process : A positional parameter cannot be found that accepts argument '/?'.
    – serenesat
    May 8, 2015 at 14:52
  • 1
    This is not really a Powershell question, it is about how to silently install the Microsoft Monitoring Agent. You should rewrite the question accordingly if you need help as there may be someone that knows how to do this, but the title won't catch their attention. May 8, 2015 at 15:40

1 Answer 1


MMASetup-i386 uses the /Q for quiet install, not /s.

Start-Process -FilePath "C:\Temp\MMASetup-i386.exe" -ArgumentList "/Q" -wait

You can often find the valid arguments for an .exe by running it with the /? argument, such as:

MMASetup-i386.exe /?

However, that is not always the case and sometimes you may need to consult the documentation or search the developer's website or the Internet in general for it.

  • Powershell will never give you a popup like you are seeing. That is the clue that the message is coming from the .exe that is being started, not from Powershell. May 8, 2015 at 14:59
  • I run above command and get this error: Error creating process << none>>. Reason: The system cannot find the file specified.
    – serenesat
    May 8, 2015 at 15:02
  • Can you tell me or edit in your answer how do we know which executable has which flag?
    – serenesat
    May 8, 2015 at 15:05
  • Hmmmm. Are you sure you got the path to the .Exe correct? The only thing you needed to change from the original command was /s to /Q May 8, 2015 at 15:06
  • 1
    @FlorianWinter See operationsmanagementsuite.org/2016/02/08/… Oct 10, 2017 at 14:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .