4

--Updates posted - scroll down--

Problem:
ASUS R510D virtualization incompatibility.
Machine specifications support AMD-V.
System is stock:
- Windows 8 home upgraded to 8.1 home
- Quadcore 64-bit AMD A10-5750M APU
- Integrated dual AMD Radeon HD 8670M crossfire
http://www.newegg.com/Product/Product.aspx?Item=N82E16834231521
http://www.notebookcheck.net/AMD-A-Series-A10-5750M-Notebook-Processor.92882.0.html

Symptom:
"kernel panic - not syncing: Attempted to kill init!" on boot

The stack trace appears to descend into functions attempting to identify the 64-bit CPU model. Stack trace shows last function call is "identify_cpu".

Attempted solutions:
I have tried every combination of virtualization and CPU settings in the VM settings. This includes:

  • Options for "Version" when "Type" is set to "Linux" in the VM settings "General -> Basic" tab

    • Linux 2.2
    • Linux 2.4
    • Linux 2.6
    • Ubuntu
    • Oracle
    • Other Linux
      These options are each available in "32 bit" and "64 bit". When set to 32-bit and attempting to boot a 64-bit kernel, the kernel behaves as expected (ie error message about bitness).
  • Chipset

    • PIIX3
    • ICH9
  • Pointing device

    • PS/2 Mouse
    • USB Tablet
  • I/O APIC enabled/disabled

  • EFI enabled/disabled
  • Processor count from 1 through 4
  • PAE/NX enabled/disabled
  • VT-x/AMD-V enabled/disabled
  • 2D Video Acceleration enabled/disabled
  • Audio enabled/disabled
  • Network adapter enabled/disabled
  • USB controller disabled / 1.0 / 2.0 / 3.0

  • Each of the last two or three stable VirtualBox versions (as of the time of this writing) and the next beta (as of the time of this writing)

  • The VirtualBox beta includes extra options for virtualization interface, such as "none", "legacy", "default", "minimal", etc. Combinations including each of these options were tried as well.

  • Removing all possible peripherals. It's a laptop so there's not much to remove but I made sure there weren't any disks in the drives or USB devices attached.

Working:

  • Bodhi Linux (variant of Mint) 64-bit VM
  • All non-working distros mentioned above when run on Windows 7 on Intel Core2 Duo or Quadcore i7 laptop

Kernel Panics:

  • Current 64-bit Minimal Linux Live ISO (which uses an up-to-date kernel as of February 2015) (http://minimal.linux-bg.org/)
  • PCLinuxOS
  • GoboLinux
  • Slax
  • and more

Additional Info:

The Minimal Linux Live ISO DID boot successfully at least once. I have no idea what I did that got it to boot or subsequently prevented it from booting. Update note: I'm starting to think I must have been mistaken.

The ASUS laptop does not have any virtualization settings available in the BIOS settings.

I have read forums that indicate that there is a problem with Realtek wireless drivers and that disabling the onboard wireless in host BIOS prevents the VM kernel panic, but this BIOS has no options for disabling internal wireless. I have not found any direct solutions but a high percentage of issues seem to involve ASUS boards from the last 5 years.

Todo:
- Include links to referenced posts containing relevant information
- Include VirtualBox logs and screenshot of kernel panic
- Test same distros on other virtualization clients (any suggestions?)
- Test same distros on Linux hosts (I'm pretty sure most of them work on Intel hardware)

See also post on VirtualBox forums


Updates:
I have attached the VirtualBox log and screenshots on my post on the VirtualBox forums. I have also found VMware Player does not have these problems. It's possible that there is still some problem with the same bug in VMware, but in VMware it doesn't stop the system from booting and running fine. I haven't gone over all of the system log and boot logging.

For now, I am content with using the noncommercial VMware in place of VirtualBox. I have been an advocate of VirtualBox but this is a clear difference in product. I may not be able to continue using VMware depending on my licensing needs, but I may not be able to continue using VirtualBox depending on my requirements. I am curious if the bug is in the kernel, VirtualBox, or something else. Perhaps QEMU or KVM would be viable.

So my actual question as stands is:
-Why didn't some 64-bit kernels work in VirtualBox on this machine?
-If it's a problem in VirtualBox, why did some distros work while others did not?
-What can be done to get the kernel to run in VirtualBox, or why can't it be done?
-Are there still related problems in VMware?

Below are results of running virtualization detection on my hardware:

AMD-V and Microsoft Hyper-V System Compatibility Utility:
(version 6.1.76 ?)
This system is compatible with Hyper-V.
This AMD64 system supports AMD Virtualization (AMD-V) with Rapid Virtualization Indexing.

Coreinfo v3.31

AMD A10-5750M APU with Radeon(tm) HD Graphics
AMD64 Family 21 Model 19 Stepping 1, AuthenticAMD
Microcode signature: 06001119
HYPERVISOR      -       Hypervisor is present
SVM             *       Supports AMD hardware-assisted virtualization
NP              *       Supports AMD nested page tables (SLAT)
  • 2
    You've asked a very good question with a lot of details, including what you've tried, which is commendable and great. However, to improve readability, I would like to recommend that you add some bulleted lists instead of long paragraphs of prose, e.g. listing the distros you've tried and whether they panicked or not. Let me know if you want help with editing. – allquixotic May 8 '15 at 19:12
  • 1
    Holy hell, your updated question is excellently formatted. Great job. I've featured this in the Root Access chat. Feel free to stop by and seek "live tech support" from one of us. chat.stackexchange.com/rooms/118/root-access – allquixotic May 8 '15 at 20:09
  • 1
    Thanks. I will probably take you up on that when I have more time later tonight. I will try to update a few more things in my question and add the logs and screenshots before then. – taz May 8 '15 at 20:10
  • 1
    "(any suggestons?)" --> VMware Workstation :) If it works for you and this is for home (non-commercial) use, I'll even help you buy a license... – allquixotic May 8 '15 at 20:23
  • 1
    You need to report this bug on lkml or bugzilla.kernel.org. – psusi May 8 '15 at 23:07
2

Have You Tried...?

A list of things that I think are worth trying, checking, or investigating:

  • Test: Did you try using a different virtualization product, even just an evaluation version? For example, maybe VMware Workstation will work fine?

  • Test: Did you try using a different host operating system, e.g. swap Windows for Linux as the host (or vice versa)? Note, do not try this until after you've tried using a different virtualization product. If the alternative virtualization product works fine, then the problem is not your operating system, so you can skip this test.

  • Test: Try removing all unnecessary guest hardware, and setting the # of CPU cores to 1 and using a very low amount of guest RAM. For that matter, make sure you close all background programs on your host OS to eliminate any possible conflicts or RAM exhaustion scenarios.

  • Check: Search VirtualBox's forums and bugzilla to see if anyone with similar hardware (specifically, a modern AMD CPU) is having a similar problem. It could be a known issue. If a developer "in the know" has replied acknowledging the problem, then it isn't "your fault" -- it's just that the software is currently broken and needs a patch.


Things you have tried but I wasn't careful enough to glean from your original post

I'm keeping these here for posterity's sake in case they help someone else:

  • Check: Did you look in the BIOS to verify that AMD-V and any other relevant virtualization features are enabled? They could easily be disabled by default; this is the case on quite a few systems for some reason.

  • Test: Try different versions of VirtualBox?


###Missing Information

I am missing a bit of information that might help me debug this problem. Maybe it is somewhere in your question and I missed it, in which case, I apologize.

  • Please list your host operating system, version, and bitness (64 or 32).
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.