1

How does one go about creating a VPN between 2 W8.1 Pro machines each on a different WAN and in different location - specifically without using 3rd party software, but only using the built in features for such. I have explored the internet extensively and experimented with all the relevant parts of such (eg. Windows firewall, router firewall, port forwarding, router pass-through etc) exhaustively without any success. Has anyone ever managed to do this?

It SHOULD be easy, given the instructions on the MS website and other sites (eg: client / Server/Firewall), but, even having followed all of the instructions (incl port forwarding, pass-through etc), I still can't get a connection.

Below are details of the configurations.


Connections:

(both computers are regular W8.1 Pro NOT Windows Servers)

The W8.1 Pro client (henceforth the 'Client') is connected via my Virgin Super Hub router (Netgear VMDG480).

The W8.1 Pro server (henceforth the 'Server') is connect via a BT Business Hub 3, which gets it's signal from a VDSL2 modem. (ECI Telecom b-focus v-2fub/r Rev B)

The server is located 5 miles from the client.


Router at client end:

The WAN IP, though I haven't paid for static, ALWAYS stays the same.(regularly checked)

I've opened up the following ports: 1723/TCP, 3389/TCP, 1701/TCP&UDP, 50/TCP, 51/TCP, 500/TCP&UDP, 4500/TCP&UDP, 5900/TCP. ALL pointing to the Client PC

It's my understanding re the Client router that setting 1723 automatically sets GRE.


Router at Server end:

The WAN IP is static (purchased from BT for this purpose).

I've opened the following ports: 1723/TCP 4567/TCP&UDP (BT backdoor port), 3389/TCP 5900/TCP, 3389/TCP, ALL pointing to the Server pc.

(I couldn't set 500/UDP or 4500/UDP on the Server router because it kept giving me the following error 'Conflict: If using VPN termination equipment in DMZ BT Wi-Fi should be disable first'. The DMZ is off, and I've tried disabling the Wi-Fi and adding 500/4500 but I get the same message)

I have set the router firewall to default, and I've disable Sip ALG just in case.


Client PC:

I've created a VPN connection to the Server via the Network and Sharing Center. (that is to say that I have gone to 'control panel/network and sharing centre/set up a connection or network/connect to a workplace' and entered the ip address of the server so that I can then use the charms bar to select the VPN connection to 'dial' the Server)


Server PC:

I've successfully set up an 'Incoming Connections' via the Network and Sharing Center. I've created a user, and recorded the username and password for such. I've ticked the IPv4, IPv6, 'File and Sharing for Microsoft Networks', and the QoS Packet Scheduler boxes in the 'Incoming Connections' properties. I've allowed all of the above ports through the firewall. I've allowed Remote access to the computer via System Properties/Remote. ALL files etc are set to 'Shared' (and they can be accessed via Homegroup from the Client pc when on the same network)


I am using Chrome Remote Desktop to alter setting/test VPN connection on the Server

I DO NOT get a connection from either PC to the other via VPN, all I get is a time out and an 868 error message. "The remote connection was not made because the name of the remote access server did not resolve."

On the server I've checked the Default Gateway IP via 'ipconfig /all', and it is different from the gateway IP given on the router: ipconfig says it is 192.168.1.254, whereas the router gives it as 81.134.160.1, I'm guessing that they are referring to different things.

  • ANYTHING? ANY IDEAS? – Marodo May 27 '15 at 12:37
0

HTG has a good article, How to Create a VPN Server on Your Windows Computer Without Installing Any Software. It is a good step-by-step walk-through of how to set it up and explains its limitations.

  • I did all of that on day 1, I've spent the last 2 months trying to get it to actually work. – Marodo May 20 '15 at 17:48
-1

Which part is failing for you? The client side or the server side?

You can test the client by trying to connect to a free VPN service (Try googling on free vpn services).

If it's the server, make sure you've port forwarded. You can check this by using a port scanner like this one. I'm guessing you're trying to setup a PPTP tunnel and so if "VPN [PPTP]" is accessible on that page then you've port forwarded correctly.

If it is accessible from that page but still not working, post another comment.

  • I've checked the ports with the website locally and the ports 3389 and 1723 are open, I haven't checked the remote pc yet as it's 5 miles away, – Marodo May 9 '15 at 12:32
  • Please see above, I had to edit my original post as the 'comment' was too long. – Marodo May 9 '15 at 12:34
  • Right. Sorry for the confusion. I meant checking the port on the remove computer. Check if you can use a free vpn service from your client. – Carlgo11 May 9 '15 at 16:50
  • I went in and had a look at the remote w8.1. I reset the router, then added RDC and VNC as presets and also added 1723, 47, and 5900 manually. When I did the port scan I got a fat zero on everything. I double checked the router and the open ports where definitely there. – Marodo May 11 '15 at 18:18
  • @Marodo make sure that the remote computer is on when you scan. – Carlgo11 May 12 '15 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.