2

I am trying to connect to local ip via SSH from terminal. Command is

ssh -v user@192.168.0.2

But it is not connecting. Keeps giving me the error "Permission denied (publickey,password)." I have been searching for ages and just cant find what the issue is. I can connect using the same method via Putty on windows and can connect via filezilla

Full output:

OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: Connecting to 192.168.0.2 [192.168.0.2] port 22.
debug1: Connection established.
debug1: identity file /Users/[UserName]/.ssh/id_rsa type 1
debug1: identity file /Users/UserName/.ssh/id_rsa-cert type -1
debug1: identity file /Users/UserName/.ssh/id_dsa type -1
debug1: identity file /Users/UserName/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4+deb7u2
debug1: match: OpenSSH_6.0p1 Debian-4+deb7u2 pat OpenSSH*
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: [Server Host Key]
debug1: Host '192.168.0.2' is known and matches the RSA host key.
debug1: Found key in /Users/[UserName]/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/[UserName]/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /Users/[UserName]/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey,password).
  • From the output, it looks like ssh is trying to use an identiy file (lines 5-8 inclusive). If you have an identity file you are using, be sure the permissions are set so only the owner can read/write. – Sarge May 8 '15 at 23:10
  • What should the permissions be? -rw------- 1 Username staff 314 9 May 00:08 id_ecdsa -rw-r--r-- 1 Username staff 199 9 May 00:08 id_ecdsa.pub -rw------- 1 Username staff 1766 8 May 22:40 id_rsa -rw-r--r-- 1 Username staff 419 8 May 22:40 id_rsa.pub -rw-r--r-- 1 Username staff 799 8 May 23:10 known_hosts – Harnamc May 8 '15 at 23:12
4

try to add the key again. first set PasswordAuthentication yes in sshd_config at dest machine, then do ssh-copy-id user@host log in, then it will copy the key over. Now you can set PasswordAuthentication no(if you want, for extra security) , and you should be able to log in automatically. You could also use your curiosity and check if id_rsa.pub from the source machine is in authorized_keys on the dest machine

  • also, I don't think permisions are the issue, but i've read that chmod 600 is fine for all files in ~/.ssh with 700 for the directory itself so you can list the files in it. Certainly anything less would be a problem – barlop May 9 '15 at 1:05
  • Spot on mate! worked like a charm – Harnamc May 9 '15 at 10:05
2

It might be different because it looks like you are connecting to localhost or something (192.168.0.2 or is that just for the question?).

What often solves things like this is to edit the ~/.ssh/known_hosts file and delete the entry for the domain you are connecting to, it will re-prompt you for ssh credentials and avoid problems caused by incorrect "expectations".

  • The localhost 192.168.0.2 is a local vpn server that has ssh enabled. I can connect to it from any other means. I have deleted the entire in the ~/.ssh/known_hosts and also completely removed the file and recreated it. But the problem still exists. Its issue is just when trying to connect from my mac. I have tried connection via putty from my window laptop and it works fine. Even sftp via filezilla works perfectly fine. – Harnamc May 9 '15 at 0:55
  • Also try deleting id_rsa.pub ? – beroe May 9 '15 at 1:11
  • @beroe I think id_rsa.pub doesn't do much. I vaguely recall from a test that it seems ssh works the same with or without id_rsa.pub . I think ssh doesn't use the public key in the pub file even though the contents are the same. – barlop May 9 '15 at 1:39
  • 1
    Tried removing and recreating all the keys still had same problem. What worked was set PasswordAuthentication yes in sshd_config and copy keys accross with ssh-copy-id user@host – Harnamc May 9 '15 at 10:34
  • Glad you got it figured out and thanks for the update. – beroe May 9 '15 at 15:38
0

first run cat $HOME/.ssh/id_rsa.pub on your computer you will get a key. save this key somewhere.

Then open this file by running vim $HOME/.ssh/authorized_keys on the computer that your are sshing to. Then copy the key in a new line of this file and close it by typing :wq

you are all set.

  • On top of that OpenSSH package includes ssh-copy-id command which basically does the some in one command – maoizm Oct 22 '18 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.